On Fri, Nov 21, 2014 at 09:42:25PM +0100, Thierry Reding wrote: > On Fri, Nov 21, 2014 at 09:38:40PM +0100, Daniel Vetter wrote: > > On Fri, Nov 21, 2014 at 03:28:32PM -0500, Rob Clark wrote: > > > +#define drm_crtc_for_each_plane(plane, crtc) \ > > > + list_for_each_entry((plane), &(crtc)->dev->mode_config.plane_list, head) \ > > > + if ((crtc)->state->plane_mask & (1 << drm_plane_index(plane))) > > > > Implement this as drm_crtc_for_each_pending_plane(plane, (crtc)->state)? > > Which means _pending is a strange name ... > > Yeah, I think the drm_crtc_for_each_pending_plane() could be > drm_crtc_state_for_each_plane(), then your suggestion makes perfect > sense. I like Thierry's naming here. Rob can you apply that please? Thanks, Daniel -- Daniel Vetter Software Engineer, Intel Corporation +41 (0) 79 365 57 48 - http://blog.ffwll.ch _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx http://lists.freedesktop.org/mailman/listinfo/dri-devel