On Mon, Oct 13, 2014 at 04:13:16PM +0200, Andrzej Hajda wrote: > On 10/13/2014 12:16 PM, Thierry Reding wrote: > > From: Thierry Reding <treding@xxxxxxxxxx> > > > > Use the newly introduced mipi_dsi_set_maximum_return_packet_size() > > function to replace an open-coded version. > > > > Signed-off-by: Thierry Reding <treding@xxxxxxxxxx> > > --- > > drivers/gpu/drm/panel/panel-s6e8aa0.c | 16 ++-------------- > > 1 file changed, 2 insertions(+), 14 deletions(-) > > > > diff --git a/drivers/gpu/drm/panel/panel-s6e8aa0.c b/drivers/gpu/drm/panel/panel-s6e8aa0.c > > index 0f85a7c37687..c31e2953f290 100644 > > --- a/drivers/gpu/drm/panel/panel-s6e8aa0.c > > +++ b/drivers/gpu/drm/panel/panel-s6e8aa0.c > > @@ -800,27 +800,15 @@ static void s6e8aa0_panel_init(struct s6e8aa0 *ctx) > > } > > > > static void s6e8aa0_set_maximum_return_packet_size(struct s6e8aa0 *ctx, > > - int size) > > + u16 size) > > > I guess this whole function should be removed and direct call to > mipi_dsi_set_maximum_return_packet_size should be used. There's additional error handling logic in this function which would have needed extra untangling. Since I don't have the hardware to test this change I kept it to a minimum possible to reduce the risk of accidentally breaking anything. Feel free to send a follow-on patch cleaning this up as you see fit. Thierry
Attachment:
pgpGSU_kasJ5D.pgp
Description: PGP signature
_______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx http://lists.freedesktop.org/mailman/listinfo/dri-devel