On Mon, Feb 3, 2014 at 7:14 AM, Inki Dae <inki.dae@xxxxxxxxxxx> wrote: > 2014-01-31 Josh Boyer <jwboyer@xxxxxxxxxxxxxxxxx>: >> On Fri, Jan 31, 2014 at 1:09 AM, Sachin Kamat <sachin.kamat@xxxxxxxxxx> wrote: >>> 'hdmi_infoframe' is already defined in include/linux/hdmi.h. >>> Rename the local variable to avoid the following build error: >>> drivers/gpu/drm/exynos/exynos_hdmi.c:382:8: error: 'hdmi_infoframe' defined as wrong kind of tag >>> struct hdmi_infoframe { >>> >>> Signed-off-by: Sachin Kamat <sachin.kamat@xxxxxxxxxx> >>> Reported-by: Josh Boyer <jwboyer@xxxxxxxxxxxxxxxxx> >> >> This does fix the build error I saw. I don't have hardware to test >> the results with, but it now compiles correctly. Thanks for the quick >> turn around! >> > > Hi, > > Thanks for report and patch. But Sean posted already below patch, > [PATCH v4 01/34] drm/exynos: Rename hdmi_infoframe to avoid collision > Yeah, sorry, I just tucked it in with the rest of my stuff :) Sean > Thanks, > Inki Dae > > >> josh >> >>> --- >>> drivers/gpu/drm/exynos/exynos_hdmi.c | 6 +++--- >>> 1 file changed, 3 insertions(+), 3 deletions(-) >>> >>> diff --git a/drivers/gpu/drm/exynos/exynos_hdmi.c b/drivers/gpu/drm/exynos/exynos_hdmi.c >>> index a0e10ae..0d4407c 100644 >>> --- a/drivers/gpu/drm/exynos/exynos_hdmi.c >>> +++ b/drivers/gpu/drm/exynos/exynos_hdmi.c >>> @@ -379,7 +379,7 @@ static const struct hdmiphy_config hdmiphy_v14_configs[] = { >>> }, >>> }; >>> >>> -struct hdmi_infoframe { >>> +struct hdmi_frameinfo { >>> enum HDMI_PACKET_TYPE type; >>> u8 ver; >>> u8 len; >>> @@ -682,7 +682,7 @@ static u8 hdmi_chksum(struct hdmi_context *hdata, >>> } >>> >>> static void hdmi_reg_infoframe(struct hdmi_context *hdata, >>> - struct hdmi_infoframe *infoframe) >>> + struct hdmi_frameinfo *infoframe) >>> { >>> u32 hdr_sum; >>> u8 chksum; >>> @@ -985,7 +985,7 @@ static void hdmi_conf_reset(struct hdmi_context *hdata) >>> >>> static void hdmi_conf_init(struct hdmi_context *hdata) >>> { >>> - struct hdmi_infoframe infoframe; >>> + struct hdmi_frameinfo infoframe; >>> >>> /* disable HPD interrupts from HDMI IP block, use GPIO instead */ >>> hdmi_reg_writemask(hdata, HDMI_INTC_CON, 0, HDMI_INTC_EN_GLOBAL | >>> -- >>> 1.7.9.5 >>> >> _______________________________________________ >> dri-devel mailing list >> dri-devel@xxxxxxxxxxxxxxxxxxxxx >> http://lists.freedesktop.org/mailman/listinfo/dri-devel > _______________________________________________ > dri-devel mailing list > dri-devel@xxxxxxxxxxxxxxxxxxxxx > http://lists.freedesktop.org/mailman/listinfo/dri-devel _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx http://lists.freedesktop.org/mailman/listinfo/dri-devel