drm_sched_init() omits the middle operand when using the ternary operator to set the timeout_wq if one has been passed. This is a non-standardized GNU extension to the C language [1]. It decreases code readability and might be read as a bug. Furthermore, it is not consistent with all other places in drm/scheduler where the ternary operator is used. Replace the expression with the standard one. [1] https://gcc.gnu.org/onlinedocs/gcc-14.1.0/gcc/Conditionals.html Suggested-by: Marco Pagani <marpagan@xxxxxxxxxx> Signed-off-by: Philipp Stanner <pstanner@xxxxxxxxxx> --- drivers/gpu/drm/scheduler/sched_main.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/scheduler/sched_main.c b/drivers/gpu/drm/scheduler/sched_main.c index 7e90c9f95611..02cf9c37a232 100644 --- a/drivers/gpu/drm/scheduler/sched_main.c +++ b/drivers/gpu/drm/scheduler/sched_main.c @@ -1257,7 +1257,7 @@ int drm_sched_init(struct drm_gpu_scheduler *sched, sched->credit_limit = credit_limit; sched->name = name; sched->timeout = timeout; - sched->timeout_wq = timeout_wq ? : system_wq; + sched->timeout_wq = timeout_wq ? timeout_wq : system_wq; sched->hang_limit = hang_limit; sched->score = score ? score : &sched->_score; sched->dev = dev; -- 2.45.0