This patch series aims to add support for XLCDC IP of sam9x7 SoC family to the DRM subsystem.XLCDC IP has additional registers and new configuration bits compared to the existing register set of HLCDC IP. The new compatible string "microchip,sam9x75-xlcdc" is defined for sam9x75 variant of the sam9x7 SoC family.The is_xlcdc flag under driver data helps to differentiate the XLCDC and existing HLCDC code within the same driver. changes in v4: * fixed kernel warnings reported by kernel test robot. changes in v3: * Removed de-referencing the value of is_xlcdc flag multiple times in a single function. * Removed cpu_relax() call when using regmap_read_poll_timeout. * Updated xfactor and yfactor equations using shift operators * Defined CSC co-efficients in an array for code readability. changes in v2: * Change the driver compatible name from "microchip,sam9x7-xlcdc" to "microchip,sam9x75-xlcdc". * Move is_xlcdc flag to driver data. * Remove unsed Macro definitions. * Add co-developed-bys tags * Replace regmap_read() with regmap_read_poll_timeout() call * Split code into two helpers for code readablitity. Durai Manickam KR (1): drm: atmel-hlcdc: Define SAM9X7 SoC XLCDC specific registers Manikandan Muralidharan (7): mfd: atmel-hlcdc: Add compatible for sam9x75 XLCD controller drm: atmel-hlcdc: add flag to differentiate XLCDC and HLCDC IP drm: atmel-hlcdc: add LCD controller layer definition for sam9x75 drm: atmel_hlcdc: Add support for XLCDC in atmel LCD driver drm: atmel-hlcdc: add DPI mode support for XLCDC drm: atmel-hlcdc: add vertical and horizontal scaling support for XLCDC drm: atmel-hlcdc: add support for DSI output formats .../gpu/drm/atmel-hlcdc/atmel_hlcdc_crtc.c | 168 +++++++-- drivers/gpu/drm/atmel-hlcdc/atmel_hlcdc_dc.c | 99 +++++ drivers/gpu/drm/atmel-hlcdc/atmel_hlcdc_dc.h | 48 +++ .../gpu/drm/atmel-hlcdc/atmel_hlcdc_plane.c | 353 +++++++++++++++--- drivers/mfd/atmel-hlcdc.c | 1 + include/linux/mfd/atmel-hlcdc.h | 10 + 6 files changed, 584 insertions(+), 95 deletions(-) -- 2.25.1