With commit dac76a0144d31 ("fetch DPU configuration from match data"), dpu core revision was dropped in favor of using the compatible string from the device tree to select the dpu catalog being used in the device. This approach works well however also necessitates adding catalog entries for small register level details as dpu capabilities and/or features bloating the catalog unnecessarily. Examples include but are not limited to data_compress, interrupt register set, widebus etc. Introduce the dpu core revision back as an entry to the catalog so that we can just use dpu revision checks for setting register bits based on the dpu's core revision rather than catalog feature bits. changes in v5: - rename the structs in dpu_hw_intf to have the dpu_hw prefix - remove a couple of comments Abhinav Kumar (5): drm/msm/dpu: re-introduce dpu core revision to the catalog drm/msm/dpu: use dpu core's major version to enable data compress drm/msm/dpu: rename all hw_intf structs to have dpu_hw prefix drm/msm/dpu: rename enable_compression() to program_intf_cmd_cfg() drm/msm/dpu: drop DPU_INTF_DATA_COMPRESS from dpu catalog .../msm/disp/dpu1/catalog/dpu_3_0_msm8998.h | 6 +++++ .../msm/disp/dpu1/catalog/dpu_4_0_sdm845.h | 6 +++++ .../msm/disp/dpu1/catalog/dpu_5_0_sm8150.h | 6 +++++ .../msm/disp/dpu1/catalog/dpu_5_1_sc8180x.h | 6 +++++ .../msm/disp/dpu1/catalog/dpu_5_4_sm6125.h | 6 +++++ .../msm/disp/dpu1/catalog/dpu_6_0_sm8250.h | 6 +++++ .../msm/disp/dpu1/catalog/dpu_6_2_sc7180.h | 6 +++++ .../msm/disp/dpu1/catalog/dpu_6_3_sm6115.h | 6 +++++ .../msm/disp/dpu1/catalog/dpu_6_4_sm6350.h | 6 +++++ .../msm/disp/dpu1/catalog/dpu_6_5_qcm2290.h | 6 +++++ .../msm/disp/dpu1/catalog/dpu_6_9_sm6375.h | 6 +++++ .../msm/disp/dpu1/catalog/dpu_7_0_sm8350.h | 6 +++++ .../msm/disp/dpu1/catalog/dpu_7_2_sc7280.h | 6 +++++ .../msm/disp/dpu1/catalog/dpu_8_0_sc8280xp.h | 6 +++++ .../msm/disp/dpu1/catalog/dpu_8_1_sm8450.h | 6 +++++ .../msm/disp/dpu1/catalog/dpu_9_0_sm8550.h | 6 +++++ .../drm/msm/disp/dpu1/dpu_encoder_phys_cmd.c | 8 +++++-- .../drm/msm/disp/dpu1/dpu_encoder_phys_vid.c | 18 +++++++------- .../gpu/drm/msm/disp/dpu1/dpu_hw_catalog.c | 2 +- .../gpu/drm/msm/disp/dpu1/dpu_hw_catalog.h | 19 +++++++++++---- drivers/gpu/drm/msm/disp/dpu1/dpu_hw_intf.c | 22 +++++++++-------- drivers/gpu/drm/msm/disp/dpu1/dpu_hw_intf.h | 24 ++++++++++++------- drivers/gpu/drm/msm/disp/dpu1/dpu_rm.c | 2 +- 23 files changed, 155 insertions(+), 36 deletions(-) -- 2.40.1