Hi Dmitry, On Mon, Jun 26, 2023 at 6:11 PM Dmitry Osipenko <dmitry.osipenko@xxxxxxxxxxxxx> wrote: > On 6/25/23 18:36, Geert Uytterhoeven wrote: > > On Sun, Jun 25, 2023 at 2:41 PM Dmitry Osipenko > > <dmitry.osipenko@xxxxxxxxxxxxx> wrote: > >> On 6/25/23 11:47, Geert Uytterhoeven wrote: > >>> On Sun, Apr 16, 2023 at 1:55 PM Dmitry Osipenko > >>> <dmitry.osipenko@xxxxxxxxxxxxx> wrote: > >>>> Add sync object DRM UAPI support to VirtIO-GPU driver. Sync objects > >>>> support is needed by native context VirtIO-GPU Mesa drivers, it also will > >>>> be used by Venus and Virgl contexts. > >>>> > >>>> Reviewed-by; Emil Velikov <emil.velikov@xxxxxxxxxxxxx> > >>>> Signed-off-by: Dmitry Osipenko <dmitry.osipenko@xxxxxxxxxxxxx> > >>> > >>> Thanks for your patch! > >>> > >>>> --- a/drivers/gpu/drm/virtio/virtgpu_submit.c > >>>> +++ b/drivers/gpu/drm/virtio/virtgpu_submit.c > >>> > >>>> +static int > >>>> +virtio_gpu_parse_deps(struct virtio_gpu_submit *submit) > >>>> +{ > >>>> + struct drm_virtgpu_execbuffer *exbuf = submit->exbuf; > >>>> + struct drm_virtgpu_execbuffer_syncobj syncobj_desc; > >>>> + size_t syncobj_stride = exbuf->syncobj_stride; > >>>> + u32 num_in_syncobjs = exbuf->num_in_syncobjs; > >>>> + struct drm_syncobj **syncobjs; > >>>> + int ret = 0, i; > >>>> + > >>>> + if (!num_in_syncobjs) > >>>> + return 0; > >>>> + > >>>> + /* > >>>> + * kvalloc at first tries to allocate memory using kmalloc and > >>>> + * falls back to vmalloc only on failure. It also uses GFP_NOWARN > >>> > >>> GFP_NOWARN does not exist. > >> > >> https://elixir.bootlin.com/linux/v6.4-rc7/source/include/linux/gfp_types.h#L38 > > > > That line defines "__GFP_NOWARN", not "GFP_NOWARN". > > C is case- and underscore-sensitive. as is "git grep -w" ;-) > > The removal of underscores was done intentionally for improving > readability of the comment Please don't do that, as IMHO it actually hampers readability: 1. For some xxx, both GFP_xxx and __GFP_xxx are defined, so it does matter which one you are referring to, 2. After dropping the underscores, "git grep -w" can no longer find the definition, nor its users. Thanks! Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds