Rename struct ast_private to struct ast_device. The old name comes from the time when struct drm_device.dev_private was still in use. Also update the upcast helper. The renaming touches ast's I/O-helper macros, which generate warnings with checkpatch. So fix the I/O helpers in the first two patches of this patchset. Tested on AST2100 hardware. Thomas Zimmermann (4): drm/ast: Remove little-endianism from I/O helpers drm/ast: Rework definition of I/O read and write helpers drm/ast: Rename struct ast_private to struct ast_device drm/ast: Rename to_ast_private() to to_ast_device() drivers/gpu/drm/ast/ast_dp.c | 10 ++-- drivers/gpu/drm/ast/ast_dp501.c | 40 +++++++------- drivers/gpu/drm/ast/ast_drv.c | 2 +- drivers/gpu/drm/ast/ast_drv.h | 84 ++++++++++++----------------- drivers/gpu/drm/ast/ast_i2c.c | 8 +-- drivers/gpu/drm/ast/ast_main.c | 24 ++++----- drivers/gpu/drm/ast/ast_mm.c | 4 +- drivers/gpu/drm/ast/ast_mode.c | 78 +++++++++++++-------------- drivers/gpu/drm/ast/ast_post.c | 94 ++++++++++++++++----------------- 9 files changed, 163 insertions(+), 181 deletions(-) -- 2.39.2