From: John Harrison <John.C.Harrison@xxxxxxxxx> When trying to analyse bug reports from CI, customers, etc. it can be difficult to work out exactly what is happening on which GT in a multi-GT system. So add GT oriented debug/error message wrappers. If used instead of the drm_ equivalents, you get the same output but with a GT# prefix on it. This patch set updates the gt/intel_gt*.c files to use the new helpers as a first step. The intention would be to convert all output messages throughout the driver as long as they have access to a GT structure. v2: Go back to using lower case names, add more wrapper sets (combined review feedback). Also, wrap up probe injection and WARN entries. v3: Split definitions out to separate header files. Tweak some messages. Wrap a couple more functions. (review feedback from Jani and Michal W). Convert all gt/intel_gt*.c but drop the GuC/HuC/CT files as too much bikeshedding about formatting. Signed-off-by: John Harrison <John.C.Harrison@xxxxxxxxx> John Harrison (1): drm/i915/gt: Start adding module oriented dmesg output drivers/gpu/drm/i915/gt/intel_gt.c | 96 +++++++++---------- .../gpu/drm/i915/gt/intel_gt_clock_utils.c | 8 +- drivers/gpu/drm/i915/gt/intel_gt_irq.c | 9 +- drivers/gpu/drm/i915/gt/intel_gt_mcr.c | 9 +- drivers/gpu/drm/i915/gt/intel_gt_pm.c | 9 +- drivers/gpu/drm/i915/gt/intel_gt_print.h | 51 ++++++++++ drivers/gpu/drm/i915/gt/intel_gt_sysfs.c | 4 +- drivers/gpu/drm/i915/gt/intel_gt_sysfs_pm.c | 34 ++----- drivers/gpu/drm/i915/gt/intel_gtt.c | 7 +- 9 files changed, 129 insertions(+), 98 deletions(-) create mode 100644 drivers/gpu/drm/i915/gt/intel_gt_print.h -- 2.39.0