Add a helper function and make drivers that have the same logic in their struct drm_crtc_helper_funcs .atomic_check handler to use this instead. Patch #1, #2 and #3 are just cleanups for the mgag200, simpledrm and ssd130x drivers respectively. Finally patch #4 converts the last two drivers to use a helper instead of open coding it the same logic. The changes are inspired by a patch from Thomas Zimmermann for the ast DRM driver: https://patchwork.kernel.org/project/dri-devel/patch/20221010103625.19958-4-tzimmermann@xxxxxxx/ This is a v2 that addresses issues pointed out also by Thomas in v1: https://lists.freedesktop.org/archives/dri-devel/2022-October/375363.html Best regards, Javier Changes in v2: - Reference drm_plane_helper_atomic_check() from drm_crtc_atomic_check() kernel doc comments and viceversa (Thomas Zimmermann). Javier Martinez Canillas (4): drm/mgag200: Do not call drm_atomic_add_affected_planes() drm/simpledrm: Do not call drm_atomic_add_affected_planes() drm/ssd130x: Do not call drm_atomic_add_affected_planes() drm/crtc-helper: Add a drm_crtc_helper_atomic_check() helper drivers/gpu/drm/drm_crtc_helper.c | 26 ++++++++++++++++++++++++++ drivers/gpu/drm/drm_plane_helper.c | 4 +++- drivers/gpu/drm/mgag200/mgag200_mode.c | 2 +- drivers/gpu/drm/solomon/ssd130x.c | 20 ++------------------ drivers/gpu/drm/tiny/simpledrm.c | 20 ++------------------ include/drm/drm_crtc_helper.h | 2 ++ 6 files changed, 36 insertions(+), 38 deletions(-) -- 2.37.3