On Thu, Apr 04, 2013 at 06:24:24PM +0200, Laurent Pinchart wrote: > Hi Ville, > > On Wednesday 27 March 2013 19:15:31 Ville Syrjälä wrote: > > On Wed, Mar 27, 2013 at 05:57:20PM +0200, Ville Syrjälä wrote: > > > On Tue, Mar 19, 2013 at 03:55:50PM +0100, Laurent Pinchart wrote: > > > > Extend the -P option to allow specifying the plane x and y offsets. The > > > > position is optional, if not specified the plane will be positioned at > > > > the center of the screen as before. > > > > > > > > Signed-off-by: Laurent Pinchart <laurent.pinchart@xxxxxxxxxxxxxxxx> > > > > --- > > > > > > > > tests/modetest/modetest.c | 72 ++++++++++++++++++++++++++++++---------- > > > > 1 file changed, 57 insertions(+), 15 deletions(-) > > > > > > > > diff --git a/tests/modetest/modetest.c b/tests/modetest/modetest.c > > > > index 7153a40..f95efe6 100644 > > > > --- a/tests/modetest/modetest.c > > > > +++ b/tests/modetest/modetest.c > > > > @@ -645,6 +645,7 @@ struct connector_arg { > > > > > > > > struct plane_arg { > > > > > > > > uint32_t con_id; /* the id of connector to bind to */ > > > > > > > > + uint32_t x, y; > > > > > > I'd like the coordinates to allow negative values too. > > > > Tested it and it actually works w/ negative values thanks to the way > > strtoul() works :) The only real obstacle is the magic '-1' handling. > > I guess you should just give up on magic values and add some flag to > > indicate whether the user provided the coords or not. > > Done :-) I'll post a new version. > > > Also I must say that I don't like the syntax you used for specifying the > > coords. '(' and ')' need to be escaped or the shell eats them. I've been > > using the x11 -geometry syntax whenever I have to deal with the x/y/w/h > > combination. It's a reasonably well known syntax and doesn't have these > > shell issues. Maybe you could use it here as well. > > Given that negative coordinates in the X geometry syntax don't match we what > need, should I keep the current syntax, abuse the X geometry syntax, or use > something else ? Since no-one suggeste anything better, I vote for the abuse. I've already gotten used to it :) -- Ville Syrjälä Intel OTC _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx http://lists.freedesktop.org/mailman/listinfo/dri-devel