Hi, These patches used to be part of the series: https://lore.kernel.org/all/20220221134155.125447-1-maxime@xxxxxxxxxx/ but since the main patch got superseded by another core patch, I've split the cleanup patches out into their own series. Let me know what you think, Maxime Changes from v1: - Used DRM_PLANE_COMMIT_ACTIVE_ONLY to skip atomic_flush Maxime Ripard (7): drm/vc4: kms: Take old state core clock rate into account drm/vc4: hvs: Fix frame count register readout drm/vc4: hvs: Store channel in variable drm/vc4: hvs: Remove dlist setup duplication drm/vc4: hvs: Move the dlist setup to its own function drm/vc4: kms: Ignore atomic_flush if we're disabled drm/vc4: hvs: Use pointer to HVS in HVS_READ and HVS_WRITE macros drivers/gpu/drm/vc4/vc4_crtc.c | 14 ++-- drivers/gpu/drm/vc4/vc4_drv.h | 15 ++-- drivers/gpu/drm/vc4/vc4_hvs.c | 127 ++++++++++++++++++++------------- drivers/gpu/drm/vc4/vc4_kms.c | 13 ++-- drivers/gpu/drm/vc4/vc4_regs.h | 12 +++- 5 files changed, 115 insertions(+), 66 deletions(-) -- 2.35.1