As we try to reduce our i915-only helpers, let's try to improve IS_ACTIVE() logic and move to kconfig.h. I'm not 100% happy with the name, but it's the best I could come up with, hopefully a little better than trying to add IS_ACTIVE() to be used broadly. Lucas De Marchi (3): drm/i915: rename IS_ACTIVE drm/i915/utils: do not depend on config being defined Move IS_CONFIG_NONZERO() to kconfig.h drivers/gpu/drm/i915/gem/i915_gem_context.c | 2 +- drivers/gpu/drm/i915/gem/i915_gem_mman.c | 2 +- drivers/gpu/drm/i915/gt/intel_engine.h | 4 ++-- drivers/gpu/drm/i915/gt/intel_engine_heartbeat.c | 2 +- drivers/gpu/drm/i915/gt/intel_engine_types.h | 2 +- .../gpu/drm/i915/gt/intel_execlists_submission.c | 2 +- .../gpu/drm/i915/gt/selftest_engine_heartbeat.c | 4 ++-- drivers/gpu/drm/i915/gt/selftest_execlists.c | 14 +++++++------- drivers/gpu/drm/i915/i915_config.c | 2 +- drivers/gpu/drm/i915/i915_request.c | 2 +- drivers/gpu/drm/i915/i915_utils.h | 13 ------------- include/linux/kconfig.h | 16 ++++++++++++++-- 12 files changed, 32 insertions(+), 33 deletions(-) -- 2.33.0