Hi Jerry, On Tue, 26 Nov 2019 at 08:14, Jerry Han <jerry.han.hq@xxxxxxxxx> wrote: > > Support Boe Himax8279d 8.0" 1200x1920 TFT LCD panel, it is a MIPI DSI > panel. > > V9: > - Adjust init code, make the format more concise > - kill off default_off_cmds (Emil) > - use mipi_dsi_dcs_set_display_{on,off} in their enable/disable > callbacks. (Emil) > - Adjusting the delay function (Emil) > > V8: > - modify PARENTHESIS_ALIGNMENT format (Sam) > - use gpios are required API replace optional gpio API (Emil) > > V7: > - Modify communication address > > V6: > - Add the information of the reviewer > - Remove unnecessary delays, The udelay_range code gracefully returns > without hitting the scheduler on a delay of 0. (Derek) > - Merge the same data structures, like display_mode and off_cmds (Derek) > - Optimize the processing of results returned by > devm_gpiod_get_optional (Derek) > > V5: > - Add the information of the reviewer (Sam) > - Delete unnecessary header files #include <linux/fb.h> (Sam) > - The config DRM_PANEL_BOE_HIMAX8279D appears twice. Drop one of them (Sam) > - ADD static, set_gpios function is not used outside this module (Sam) > > V4: > - Frefix all function maes with boe_ (Sam) > - Fsed "enable_gpio" replace "reset_gpio", Make it look clearer (Sam) > - Sort include lines alphabetically (Sam) > - Fixed entries in the makefile must be sorted alphabetically (Sam) > - Add send_mipi_cmds function to avoid duplicating the code (Sam) > - Add the necessary delay(reset_delay_t5) between reset and sending > the initialization command (Rock wang) > > V3: > - Remove unnecessary delays in sending initialization commands (Jitao Shi) > > V2: > - Use SPDX identifier (Sam) > - Use necessary header files replace drmP.h (Sam) > - Delete unnecessary header files #include <linux/err.h> (Sam) > - Specifies a GPIOs array to control the reset timing, > instead of reading "dsi-reset-sequence" data from DTS (Sam) > - Delete backlight_disable() function when already disabled (Sam) > - Use devm_of_find_backlight() replace of_find_backlight_by_node() (Sam) > - Move the necessary data in the DTS to the current file, > like porch, display_mode and Init code etc. (Sam) > - Add compatible device "boe,himax8279d10p" (Sam) > > V1: > - Support Boe Himax8279d 8.0" 1200x1920 TFT LCD panel, it is a MIPI DSI > panel. > > Signed-off-by: Jerry Han <jerry.han.hq@xxxxxxxxx> > Reviewed-by: Sam Ravnborg <sam@xxxxxxxxxxxx> > Reviewed-by: Derek Basehore <dbasehore@xxxxxxxxxxxx> > Reviewed-by: Emil Velikov <emil.l.velikov@xxxxxxxxx> Please don't add tags unless they are explicitly provided by the individual. Namely you're just sending this revision, so I'm yet to review it. > Cc: Jitao Shi <jitao.shi@xxxxxxxxxxxx> > Cc: Rock wang <rock_wang@xxxxxxxxxxxx> > --- > MAINTAINERS | 6 + > drivers/gpu/drm/panel/Kconfig | 11 + > drivers/gpu/drm/panel/Makefile | 2 + > drivers/gpu/drm/panel/panel-boe-himax8279d.c | 990 +++++++++++++++++++ > 4 files changed, 1009 insertions(+) > create mode 100644 drivers/gpu/drm/panel/panel-boe-himax8279d.c > > diff --git a/MAINTAINERS b/MAINTAINERS > index c2b89453805f..295cb214834c 100644 > --- a/MAINTAINERS > +++ b/MAINTAINERS > @@ -5135,6 +5135,12 @@ T: git git://anongit.freedesktop.org/drm/drm-misc > S: Maintained > F: drivers/gpu/drm/bochs/ > > +DRM DRIVER FOR BOE HIMAX8279D PANELS > +M: Jerry Han <hanxu5@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx> > +S: Maintained > +F: drivers/gpu/drm/panel/panel-boe-himax8279d.c > +F: Documentation/devicetree/bindings/display/panel/boe,himax8279d.txt > + > DRM DRIVER FOR FARADAY TVE200 TV ENCODER > M: Linus Walleij <linus.walleij@xxxxxxxxxx> > T: git git://anongit.freedesktop.org/drm/drm-misc > diff --git a/drivers/gpu/drm/panel/Kconfig b/drivers/gpu/drm/panel/Kconfig > index f152bc4eeb53..683ff77a3733 100644 > --- a/drivers/gpu/drm/panel/Kconfig > +++ b/drivers/gpu/drm/panel/Kconfig > @@ -18,6 +18,17 @@ config DRM_PANEL_ARM_VERSATILE > reference designs. The panel is detected using special registers > in the Versatile family syscon registers. > > +config DRM_PANEL_BOE_HIMAX8279D > + tristate "Boe Himax8279d panel" > + depends on OF > + depends on DRM_MIPI_DSI > + depends on BACKLIGHT_CLASS_DEVICE > + help > + Say Y here if you want to enable support for Boe Himax8279d > + TFT-LCD modules. The panel has a 1200x1920 resolution and uses > + 24 bit RGB per pixel. It provides a MIPI DSI interface to > + the host and has a built-in LED backlight. > + > config DRM_PANEL_LVDS > tristate "Generic LVDS panel driver" > depends on OF > diff --git a/drivers/gpu/drm/panel/Makefile b/drivers/gpu/drm/panel/Makefile > index b6cd39fe0f20..4beae2ab427f 100644 > --- a/drivers/gpu/drm/panel/Makefile > +++ b/drivers/gpu/drm/panel/Makefile > @@ -1,5 +1,6 @@ > # SPDX-License-Identifier: GPL-2.0 > obj-$(CONFIG_DRM_PANEL_ARM_VERSATILE) += panel-arm-versatile.o > +obj-$(CONFIG_DRM_PANEL_BOE_HIMAX8279D) += panel-boe-himax8279d.o > obj-$(CONFIG_DRM_PANEL_LVDS) += panel-lvds.o > obj-$(CONFIG_DRM_PANEL_SIMPLE) += panel-simple.o > obj-$(CONFIG_DRM_PANEL_FEIYANG_FY07024DI26A30D) += panel-feiyang-fy07024di26a30d.o > @@ -36,5 +37,6 @@ obj-$(CONFIG_DRM_PANEL_SITRONIX_ST7789V) += panel-sitronix-st7789v.o > obj-$(CONFIG_DRM_PANEL_SONY_ACX565AKM) += panel-sony-acx565akm.o > obj-$(CONFIG_DRM_PANEL_TPO_TD028TTEC1) += panel-tpo-td028ttec1.o > obj-$(CONFIG_DRM_PANEL_TPO_TD043MTEA1) += panel-tpo-td043mtea1.o > +obj-$(CONFIG_DRM_PANEL_BOE_HIMAX8279D) += panel-boe-himax8279d.o Are you sure this line is needed? The entry is already there, in the prior hunk. > obj-$(CONFIG_DRM_PANEL_TPO_TPG110) += panel-tpo-tpg110.o > obj-$(CONFIG_DRM_PANEL_TRULY_NT35597_WQXGA) += panel-truly-nt35597.o > diff --git a/drivers/gpu/drm/panel/panel-boe-himax8279d.c b/drivers/gpu/drm/panel/panel-boe-himax8279d.c > new file mode 100644 > index 000000000000..6265bf975365 > --- /dev/null > +++ b/drivers/gpu/drm/panel/panel-boe-himax8279d.c > @@ -0,0 +1,990 @@ > +// SPDX-License-Identifier: GPL-2.0 > +/* > + * Copyright (c) 2019, Huaqin Telecom Technology Co., Ltd > + * > + * Author: Jerry Han <jerry.han.hq@xxxxxxxxx> > + * > + */ > + > +#include <linux/backlight.h> > +#include <linux/delay.h> > +#include <linux/kernel.h> > +#include <linux/module.h> > +#include <linux/of.h> > +#include <linux/of_device.h> > + > +#include <linux/gpio/consumer.h> > +#include <linux/regulator/consumer.h> > + > +#include <drm/drm_device.h> > +#include <drm/drm_mipi_dsi.h> > +#include <drm/drm_modes.h> > +#include <drm/drm_panel.h> > +#include <drm/drm_print.h> > + > +#include <video/mipi_display.h> > + > +struct panel_cmd { > + size_t len; > + const char *data; > +}; Since len is always 1, I'd use struct panel_cmd { char cmd; char data; }; > + > +#define _INIT_CMD(...) { \ > + .len = sizeof((char[]){__VA_ARGS__}), \ > + .data = (char[]){__VA_ARGS__} } > + ... and kill this macro. <snip> > + > +static void set_gpios(struct panel_info *pinfo, int enable) > +{ > + gpiod_set_value(pinfo->enable_gpio, enable); > + gpiod_set_value(pinfo->pp33_gpio, enable); > + gpiod_set_value(pinfo->pp18_gpio, enable); Function is always called with "enabled = 0". I lets rename the function to "disable_gpios" and drop the enable argument. > +} > + > +static int send_mipi_cmds(struct drm_panel *panel, const struct panel_cmd *cmds) > +{ > + struct panel_info *pinfo = to_panel_info(panel); > + unsigned int i = 0; > + int err; > + > + if (!cmds) > + return -EFAULT; > + We don't need this check, since cmd will never be NULL. > + for (i = 0; cmds[i].len != 0; i++) { > + const struct panel_cmd *cmd = &cmds[i]; > + > + err = mipi_dsi_dcs_write(pinfo->link, cmd->data[0], > + cmd->data + 1, 1); With the above suggestion, this becomes err = mipi_dsi_dcs_write_buffer(pinfo->link, &cmds[i], sizeof(struct panel_cmd)); > + > + if (err < 0) > + return err; > + } > + > + return 0; > +} > + > +static int boe_panel_disable(struct drm_panel *panel) > +{ > + struct panel_info *pinfo = to_panel_info(panel); > + if (!pinfo->enabled) return 0; > + backlight_disable(pinfo->backlight); > + IMHO it's nice to call mipi_dsi_dcs_set_display_off() here. Although some drivers do that in unprepare, so feel free to take or leave this comment. > + pinfo->enabled = false; > + > + return 0; > +} > + > +static int boe_panel_unprepare(struct drm_panel *panel) > +{ > + struct panel_info *pinfo = to_panel_info(panel); > + int err; > + > + if (!pinfo->prepared) > + return 0; > + > + err = mi`pi_dsi_dcs_set_display_off(pinfo->link); > + if (err < 0) { > + DRM_DEV_ERROR(panel->dev, "failed to set display off: %d\n", > + err); > + goto poweroff; > + } I'd drop the goto and let the code continue with the teardown. > + > + err = mipi_dsi_dcs_enter_sleep_mode(pinfo->link); > + if (err < 0) { > + DRM_DEV_ERROR(panel->dev, "failed to enter sleep mode: %d\n", > + err); > + goto poweroff; Same here. > + } > + > + /* sleep_mode_delay: 1ms - 2ms */ > + usleep_range(1000, 2000); > + > + set_gpios(pinfo, 0); > + > + pinfo->prepared = false; > + > + return 0; > + > +poweroff: > + set_gpios(pinfo, 0); > + return err; ... and drop the now unused label. > +} > + > +static int boe_panel_prepare(struct drm_panel *panel) > +{ > + struct panel_info *pinfo = to_panel_info(panel); > + int err; > + ... > + if (err < 0) { > + DRM_DEV_ERROR(panel->dev, "failed to send DCS Init Code: %d\n", > + err); > + goto poweroff; Let's use something more descriptive, say "disable_gpios"? <snip> > +static int boe_panel_enable(struct drm_panel *panel) > +{ > + struct panel_info *pinfo = to_panel_info(panel); > + int ret; > + > + if (pinfo->enabled) > + return 0; > + If you like the suggestion in _disable above, them please move the mipi_dsi_dcs_set_display_on + follow-up usleep in here. > + ret = backlight_enable(pinfo->backlight); > + if (ret) { > + DRM_DEV_ERROR(panel->drm->dev, > + "Failed to enable backlight %d\n", ret); > + return ret; > + } > + > + pinfo->enabled = true; > + > + return 0; > +} > + <snip> > +static const struct of_device_id panel_of_match[] = { > + { .compatible = "boe,himax8279d8p", > + .data = &boe_himax8279d8p_panel_desc > + }, { .compatible = "boe,himax8279d10p", > + .data = &boe_himax8279d10p_panel_desc > + }, { > + /* sentinel */ > + } > +}; Style nitpick: static const struct of_device_id panel_of_match[] = { { .compatible = "boe,himax8279d8p", .data = &boe_himax8279d8p_panel_desc, }, { .compatible = "boe,himax8279d10p", .data = &boe_himax8279d10p_panel_desc, }, { /* sentinel */ }, }; > +MODULE_DEVICE_TABLE(of, panel_of_match); > + > +static int panel_add(struct panel_info *pinfo) > +{ > + struct device *dev = &pinfo->link->dev; > + int ret; > + ... > + > + ret = drm_panel_add(&pinfo->base); > + if (ret < 0) > + return ret; > + > + return 0; We can drop the ret check here: return drm_panel_add(&pinfo->base); > +} > + > +static void panel_del(struct panel_info *pinfo) > +{ > + if (pinfo->base.dev) Do we need the if check here? If not, let's inline the function. > + drm_panel_remove(&pinfo->base); > +} > + > +static int panel_probe(struct mipi_dsi_device *dsi) > +{ > + struct panel_info *pinfo; > + const struct panel_desc *desc; > + int err; > + > + pinfo = devm_kzalloc(&dsi->dev, sizeof(*pinfo), GFP_KERNEL); > + if (!pinfo) > + return -ENOMEM; > + > + desc = of_device_get_match_data(&dsi->dev); > + dsi->mode_flags = desc->mode_flags; > + dsi->format = desc->format; > + dsi->lanes = desc->lanes; > + pinfo->desc = desc; > + > + pinfo->link = dsi; > + mipi_dsi_set_drvdata(dsi, pinfo); > + > + err = panel_add(pinfo); > + if (err < 0) > + return err; > + > + return mipi_dsi_attach(dsi); We should call drm_panel_remove() when attach fails. > +} > + > +static int panel_remove(struct mipi_dsi_device *dsi) > +{ > + struct panel_info *pinfo = mipi_dsi_get_drvdata(dsi); > + int err; > + > + err = boe_panel_unprepare(&pinfo->base); > + if (err < 0) > + DRM_DEV_ERROR(&dsi->dev, "failed to unprepare panel: %d\n", > + err); > + > + err = boe_panel_disable(&pinfo->base); The sequence should be like in panel_shutdown - aka disable should be called and then unprepare. HTH Emil _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/dri-devel