On Wed, Jun 26, 2019 at 11:49 AM Daniel Vetter <daniel@xxxxxxxx> wrote: > > Bunch of naming bikesheds I appreciate the suggestions, naming is hard :). > > +#include <linux/cgroup.h> > > + > > +struct drmcgrp { > > drm_cgroup for more consistency how we usually call these things. I was hoping to keep the symbol short if possible. I started with drmcg (following blkcg), but I believe that causes confusion with other aspect of the drm subsystem. I don't have too strong of an opinion on this but I'd prefer not needing to keep refactoring. So if there are other opinions on this, please speak up. > > + > > +static inline void put_drmcgrp(struct drmcgrp *drmcgrp) > > In drm we generally put _get/_put at the end, cgroup seems to do the same. ok, I will refactor. > > +{ > > + if (drmcgrp) > > + css_put(&drmcgrp->css); > > +} > > + > > +static inline struct drmcgrp *parent_drmcgrp(struct drmcgrp *cg) > > I'd also call this drm_cgroup_parent or so. > > Also all the above needs a bit of nice kerneldoc for the final version. > -Daniel Noted, will do, thanks. Regards, Kenny _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/dri-devel