This patch series aims to clean-up differents parts of the drm meson code source. Couple macros have been defined and used to set several registers instead of using magic constants. I also took the opportunity to: - add/remove/update comments - remove useless code - minor fix/improvment Julien Masson (9): drm: meson: mask value when writing bits relaxed drm: meson: crtc: use proper macros instead of magic constants drm: meson: drv: use macro when initializing vpu drm: meson: vpp: use proper macros instead of magic constants drm: meson: viu: use proper macros instead of magic constants drm: meson: venc: use proper macros instead of magic constants drm: meson: global clean-up drm: meson: add macro used to enable HDMI PLL drm: meson: venc: set the correct macrovision max amplitude value drivers/gpu/drm/meson/meson_crtc.c | 17 ++- drivers/gpu/drm/meson/meson_drv.c | 26 +++- drivers/gpu/drm/meson/meson_dw_hdmi.c | 2 + drivers/gpu/drm/meson/meson_dw_hdmi.h | 12 +- drivers/gpu/drm/meson/meson_plane.c | 2 +- drivers/gpu/drm/meson/meson_registers.h | 136 ++++++++++++++++--- drivers/gpu/drm/meson/meson_vclk.c | 7 +- drivers/gpu/drm/meson/meson_venc.c | 169 ++++++++++++++++++------ drivers/gpu/drm/meson/meson_venc_cvbs.c | 3 +- drivers/gpu/drm/meson/meson_viu.c | 82 ++++++------ drivers/gpu/drm/meson/meson_vpp.c | 27 ++-- 11 files changed, 362 insertions(+), 121 deletions(-) -- 2.17.1 _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/dri-devel