On Fri, Apr 13, 2018 at 01:59:29PM -0700, abhinavk@xxxxxxxxxxxxxx wrote: > Hi Sean > > Thanks for the comments. > > Some replies inline. > > On 2018-04-13 13:46, Sean Paul wrote: > > On Sat, Apr 07, 2018 at 12:06:53AM -0700, Abhinav Kumar wrote: > > > Register truly panel as a backlight led device and > > > provide methods to control its backlight operation. > > > > > > Signed-off-by: Abhinav Kumar <abhinavk@xxxxxxxxxxxxxx> > > > --- <snip /> > > > + if (!ctx->backlight) { > > > + memset(&props, 0, sizeof(props)); > > > + props.type = BACKLIGHT_RAW; > > > + props.power = FB_BLANK_UNBLANK; > > > + props.max_brightness = 4096; > > > + > > > + snprintf(bl_node_name, BL_NODE_NAME_SIZE, "panel%u-backlight", > > > + PRIM_DISPLAY_NODE); > > > > Given that PRIM_DISPLAY_NODE is always 0, this seems like overkill for a > > pretty > > generic name "panel0-backlight". So let's just call it "truly_backlight" > > in the > > register call. > > > [Abhinav] The reason for keeping it "panel0-backlight" is because userspace > is using > this node name to write the backlight. Changing the name will need more > changes in our > userspace. > Unless the userspace is opensource (I'm guessing it's not?), that's not something we need to code around. It sounds like this is mostly a moot point given Bjorn's comments on the v2. Sean <snip /> -- Sean Paul, Software Engineer, Google / Chromium OS _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/dri-devel