Hi Tomi, On Wednesday 10 May 2017 01:24:52 Laurent Pinchart wrote: > On Tuesday 09 May 2017 12:23:13 Tomi Valkeinen wrote: > > On 08/05/17 14:32, Laurent Pinchart wrote: > > > The DPI code only needs to differentiate between major OMAP revisions, > > > which can be obtained from the DSS compatible string. Replace the OMAP > > > SoC model checks to prepare for removal of the OMAP SoC version platform > > > data. > > > > > > Signed-off-by: Laurent Pinchart <laurent.pinchart@xxxxxxxxxxxxxxxx> > > > --- > > > > > > drivers/gpu/drm/omapdrm/dss/dpi.c | 59 > > > ++++++++++++++-------------------- > > > drivers/gpu/drm/omapdrm/dss/dss.c | 10 ++++++- > > > drivers/gpu/drm/omapdrm/dss/dss.h | 13 +++++++-- > > > 3 files changed, 45 insertions(+), 37 deletions(-) > > > > > > diff --git a/drivers/gpu/drm/omapdrm/dss/dpi.c > > > b/drivers/gpu/drm/omapdrm/dss/dpi.c index 3d87f3af72bb..b5cb23c167db > > > 100644 > > > --- a/drivers/gpu/drm/omapdrm/dss/dpi.c > > > +++ b/drivers/gpu/drm/omapdrm/dss/dpi.c > > > @@ -39,6 +39,7 @@ > > > > > > struct dpi_data { > > > > > > struct platform_device *pdev; > > > > > > + enum dss_device_type type; > > > > I really don't like "dss_device_type" or "type" here... "dss_version"? > > Or maybe it should be tied to DPI, so "dpi_version"? > > I don't think it should be tied to the DPI, as it's really the DSS version > that matters here. I'll rename dss_device_type to dss_version. Thinking about it again, how about dss_model ? > Note that I don't think the type field should be stored in the dpi_data > structure. It should be part of the dss structure, which should become > visible to the DPI code. I plan to rework the driver in this direction, but > in the meantime I think we could merge this patch (after renaming the enum) > as it doesn't make the current situation any worse. -- Regards, Laurent Pinchart _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/dri-devel