[PATCH 0/4] drm/atomic: Cleanups for adding connector atomic check function.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Some small cleanups I came across to make drm_atomic_helper_check_modeset
more readable.

This makes it a lot more clear what atomic_check does and why it's called in
the place it is.

Maarten Lankhorst (4):
  drm/atomic: Unify conflicting encoder handling.
  drm/atomic: Set all the changed flags in one place.
  drm/atomic: Move enable/connector check up in check_modeset()
  drm/atomic: Add connector atomic_check function, v2.

 drivers/gpu/drm/drm_atomic_helper.c      | 84 ++++++++++++++++++++++----------
 include/drm/drm_atomic.h                 |  2 -
 include/drm/drm_modeset_helper_vtables.h | 34 +++++++++++++
 3 files changed, 93 insertions(+), 27 deletions(-)

-- 
2.7.4

_______________________________________________
dri-devel mailing list
dri-devel@xxxxxxxxxxxxxxxxxxxxx
https://lists.freedesktop.org/mailman/listinfo/dri-devel




[Index of Archives]     [Linux DRI Users]     [Linux Intel Graphics]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [XFree86]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [XFree86]
  Powered by Linux