On Sat, Mar 25, 2017 at 11:21:29AM +0200, Shashank Sharma wrote: > This patch adds description about 'scdc' variable in drm_hdmi_info > structure, to fix this warning during doc-build. > > "drm_connector.h:140: warning: No description found for parameter 'scdc'" > > V2: Rebase > > Cc: Daniel Vetter <daniel@xxxxxxxx> > Signed-off-by: Shashank Sharma <shashank.sharma@xxxxxxxxx> Since you're bikeshedding this to v4 already, might as well jump in too :-) > --- > include/drm/drm_connector.h | 2 ++ > 1 file changed, 2 insertions(+) > > diff --git a/include/drm/drm_connector.h b/include/drm/drm_connector.h > index f8b766d..9fba967 100644 > --- a/include/drm/drm_connector.h > +++ b/include/drm/drm_connector.h > @@ -133,6 +133,8 @@ struct drm_scdc { > * This information is available in CEA-861-F extension blocks (like HF-VSDB). > */ > struct drm_hdmi_info { > + Please no empty line here. > + /* @scdc: sink's scdc support and capabilities */ One-line struct member kerneldoc works, but you need to prefix it with /** like any other kernel-doc comment. See https://dri.freedesktop.org/docs/drm/doc-guide/kernel-doc.html#in-line-member-documentation-comments Cheers, Daniel > struct drm_scdc scdc; > }; > > -- > 2.7.4 > -- Daniel Vetter Software Engineer, Intel Corporation http://blog.ffwll.ch _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/dri-devel