On Tue, Nov 15, 2016 at 05:42:35PM +0900, Gustavo Padovan wrote: > 2016-11-15 Chris Wilson <chris@xxxxxxxxxxxxxxxxxx>: > > > On Tue, Nov 15, 2016 at 10:57:35AM +0900, Gustavo Padovan wrote: > > > diff --git a/include/drm/drm_crtc.h b/include/drm/drm_crtc.h > > > index 11780a9..0870de1 100644 > > > --- a/include/drm/drm_crtc.h > > > +++ b/include/drm/drm_crtc.h > > > @@ -32,6 +32,8 @@ > > > #include <linux/fb.h> > > > #include <linux/hdmi.h> > > > #include <linux/media-bus-format.h> > > > +#include <linux/srcu.h> > > > +#include <linux/dma-fence.h> > > > #include <uapi/drm/drm_mode.h> > > > #include <uapi/drm/drm_fourcc.h> > > > #include <drm/drm_modeset_lock.h> > > > @@ -739,9 +741,52 @@ struct drm_crtc { > > > */ > > > struct drm_crtc_crc crc; > > > #endif > > > + > > > + /** > > > + * @fence_context: > > > + * > > > + * timeline context used for fence operations. > > > + */ > > > + unsigned int fence_context; > > > + > > > + /** > > > + * @fence_lock: > > > + * > > > + * spinlock to protect the fences in the fence_context. > > > + */ > > > + > > > + spinlock_t fence_lock; > > > + /** > > > + * @fence_seqno: > > > + * > > > + * Seqno variable used as monotonic counter for the fences > > > + * created on the CRTC's timeline. > > > + */ > > > + unsigned long fence_seqno; > > > + > > > + /** > > > + * @timeline_name: > > > + * > > > + * The name of the CRTC's fence timeline. > > > + */ > > > + char timeline_name[32]; > > > }; > > > > > > /** > > > + * dma_crtc_fence_ops - fence ops for the drm_crtc timeline > > > + * > > > + * It contains the dma_fence_ops that should be called by the dma_fence > > > + * code. CRTC core should use this ops when initializing fences. > > > + */ > > > +extern const struct dma_fence_ops drm_crtc_fence_ops; > > > + > > > +static inline struct drm_crtc *fence_to_crtc(struct dma_fence *fence) > > > +{ > > > + BUG_ON(fence->ops != &drm_crtc_fence_ops); > > > + return container_of(fence->lock, struct drm_crtc, fence_lock); > > > +} > > > > If you are planning to export this for use by drivers, you are missing > > the EXPORT_SYMBOL(drm_crtc_fence_ops). > > Drivers should not be using this, at least for now. Then please put it into drm_crtc_internal.h. We should only allow drivers to use functions they're supposed to be using, and hide everything else. -Daniel -- Daniel Vetter Software Engineer, Intel Corporation http://blog.ffwll.ch _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/dri-devel