On Tue, 12 Oct 2010 10:46:52 -0500 Jason Wessel <jason.wessel@xxxxxxxxxxxxx> wrote: > On 10/12/2010 10:38 AM, Jesse Barnes wrote: > > On Tue, 12 Oct 2010 07:49:59 -0500 > > Jason Wessel <jason.wessel@xxxxxxxxxxxxx> wrote: > > > > > >> Some devices such as the pre nv02 chips have enter and exit > >> constraints where hardware compression must be turned off and > >> re-enabled on resuming normal operations. > >> > >> This patch extends the mode_set_base_atomic() call to pass an argument > >> to indicate if this is an entry or an exit from an atomic kernel mode > >> set change. Individual drm drivers can properly save and restore > >> state accordingly. > >> > >> Signed-off-by: Jason Wessel <jason.wessel@xxxxxxxxxxxxx> > >> CC: Jesse Barnes <jbarnes@xxxxxxxxxxxxxxxx> > >> CC: David Airlie <airlied@xxxxxxxx> > >> CC: dri-devel@xxxxxxxxxxxxxxxxxxxxx > >> --- > >> drivers/gpu/drm/drm_fb_helper.c | 5 +++-- > >> drivers/gpu/drm/i915/intel_display.c | 4 ++-- > >> drivers/gpu/drm/nouveau/nv04_crtc.c | 2 +- > >> drivers/gpu/drm/nouveau/nv50_crtc.c | 2 +- > >> drivers/gpu/drm/radeon/atombios_crtc.c | 2 +- > >> drivers/gpu/drm/radeon/radeon_legacy_crtc.c | 2 +- > >> drivers/gpu/drm/radeon/radeon_mode.h | 4 ++-- > >> include/drm/drm_crtc_helper.h | 3 ++- > >> 8 files changed, 13 insertions(+), 11 deletions(-) > >> > >> diff --git a/drivers/gpu/drm/drm_fb_helper.c b/drivers/gpu/drm/drm_fb_helper.c > >> index 6a5e403..625a2d5 100644 > >> --- a/drivers/gpu/drm/drm_fb_helper.c > >> +++ b/drivers/gpu/drm/drm_fb_helper.c > >> @@ -263,7 +263,8 @@ int drm_fb_helper_debug_enter(struct fb_info *info) > >> funcs->mode_set_base_atomic(mode_set->crtc, > >> mode_set->fb, > >> mode_set->x, > >> - mode_set->y); > >> + mode_set->y, > >> + 1); > >> > > > > An enum for the last arg would make this call much less mysterious. :) > > > > > Is there anything that is already predefined or would you prefer just > true or false? > > This could be changed to a bool because there are really only two > states, entering and exiting. If you provide some guidance on the > preferred naming, I can re-spin the patch. I was thinking: enum mode_set_atomic { ENTER_KDB, EXIT_KDB, }; or something similar (the name of the enum could probably be better). Just having a number or true/false always makes me have to check the function prototype. Having an enum means it's readable at the callsite. But this is really just a nitpick; bool args like this are a pet peeve of mine. :) -- Jesse Barnes, Intel Open Source Technology Center _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx http://lists.freedesktop.org/mailman/listinfo/dri-devel