Hi Laurent > > // This patch started to use C++ style comment out > > // because it is recent Linus request > > I fear this will generate lots of frustration :-/ While I strongly prefer the > traditional C style, I'm fine leaving the choice to driver authors. However, I > think that mixing different styles in the same file only hinders readability. > Would you like to convert the whole file ? ;-) I already posted v2 patch ;P > > chcr = rcar_dmac_chan_read(chan, RCAR_DMACHCR); > > if (chcr & RCAR_DMACHCR_CAE) { > > - rcar_dmac_chan_halt(chan); > > + struct rcar_dmac *dmac = dev_get_drvdata(chan->chan.device->dev); > > This could be simplified with > > struct rcar_dmac *dmac = to_rcar_dmac(chan->chan.device); Nice to know. Will post v3 patch Best regards --- Kuninori Morimoto -- To unsubscribe from this list: send the line "unsubscribe dmaengine" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html