On Sun, Jan 24, 2016 at 07:21:47PM +0000, Mans Rullgard wrote: > This patch series contains a number of mostly minor fixes and cleanups > for the DW DMA driver. A couple of them affect the DT binding so these > may need to be updated to maintain compatibility. The rest should be > relatively straight-forward. > > Andy's branch had two additional patches which I have ommitted here since > one, "dmaengine: dw: clear soft LLP flag in case of error", doesn't look > correct and the other, "dmaengine: dw: split dwc_dostart() helper to two", > depends on the first. > > Andy Shevchenko (11): > dmaengine: dw: rename masters to reflect actual topology > dmaengine: dw: substitute dma_read_byaddr by dma_readl_native > dmaengine: dw: revisit data_width property > dmaengine: dw: define counter variables as unsigned int > dmaengine: dw: keep entire platform data in struct dw_dma > dmaengine: dw: pass platform data via struct dw_dma_chip > dmaengine: dw: platform: use field-by-field initialization > dmaengine: dw: move dwc->paused to dwc->flags > dmaengine: dw: move dwc->initialized to dwc->flags > dmaengine: dw: move residue to a descriptor > dmaengine: dw: set cdesc to NULL when free cyclic transfers > > Mans Rullgard (4): > dmaengine: dw: fix byte order of hw descriptor fields > dmaengine: dw: clear LLP_[SD]_EN bits in last descriptor of a chain > dmaengine: dw: set src and dst master select according to xfer > direction > dmaengine: dw: set LMS field in descriptors > > Documentation/devicetree/bindings/dma/snps-dma.txt | 9 +- > arch/arc/boot/dts/abilis_tb10x.dtsi | 2 +- > arch/arm/boot/dts/spear13xx.dtsi | 4 +- > arch/avr32/mach-at32ap/at32ap700x.c | 16 +- > drivers/ata/sata_dwc_460ex.c | 6 +- > drivers/dma/dw/core.c | 295 ++++++++++----------- > drivers/dma/dw/pci.c | 3 +- > drivers/dma/dw/platform.c | 38 ++- > drivers/dma/dw/regs.h | 55 ++-- > drivers/spi/spi-pxa2xx-pci.c | 8 +- > drivers/tty/serial/8250/8250_pci.c | 8 +- > include/linux/dma/dw.h | 14 +- > include/linux/platform_data/dma-dw.h | 15 +- > sound/soc/intel/common/sst-firmware.c | 2 +- > 14 files changed, 241 insertions(+), 234 deletions(-) Your patch title are also misleading. Only dmaengine code should have tag "dmaengine: dw:" rest should have their own subsystem tags. This will help folks review their changes faster -- ~Vinod -- To unsubscribe from this list: send the line "unsubscribe dmaengine" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html