On Fri, Jul 10, 2015 at 11:52:05AM +0530, Vinod Koul wrote: > On Tue, Jul 07, 2015 at 01:24:22PM +0800, Shengjiu Wang wrote: > > > why not use set_bit(), you are modifying driver memory > > Original driver all use the __set_bit. do you think we need to change > > all the __set_bit to set_bit? And from the header file "arch/arm/include/asm > > /bitops.h", the set_bit is same as __set_bit. > New changes should be rightly done. __xxx denotes typically internal API to > a subsystem, so if they are same I would suggest to use set_bit() Ok, I agree with you. > > > > > + /* > > > > + * If LWML(src_maxburst) > HWML(dst_maxburst), we need > > > > + * swap LWML and HWML of INFO(A.3.2.5.1), also need swap > > > > + * r0(event_mask[1]) and r1(event_mask[0]). > > > > + */ > > > > + if (lwml > hwml) { > > > > + sdmac->watermark_level &= ~0xff00ff; > > > Magic number? > ?? I have add a description on V2 patch for the watermark_level definition. > > > > Okay the direction is depreciated, so can you store both source and > > > destination and use them based on direction in prepare() > > > > > > Also I see driver is not doing this, so while at it, can you fix this is > > > current code as well > > > > > which prepare() do you mean? sdma_prep_dma_cyclic, sdma_prep_slave_sg? > both have direction as an argument. So you need to use that I have removed the direction checking. So I think don't need to change the sdma_prep_dma_cyclic, sdma_prep_slave_sg. Anyway please review the V2 patch for this, I have sent it out. In V2, I still use the __set_bit. After you review the V2 patch, I will change them together. Thanks. wang shengjiu > > -- > ~Vinod > -- To unsubscribe from this list: send the line "unsubscribe dmaengine" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html