Re: [PATCH] ioat: fail self-test if wait_for_completion times out

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, 2015-01-07 at 13:09 +0000, Nicholas Mc Guire wrote:
> On Wed, 07 Jan 2015, Prarit Bhargava wrote:
> 
> > 
> > 
> > On 01/06/2015 10:38 AM, Jiang, Dave wrote:
> > >>>> -	if (dma->device_tx_status(dma_chan, cookie, NULL) != DMA_COMPLETE) {
> > >>>> +	if (tmo == 0 || dma->device_tx_status(dma_chan, cookie, NULL)
> > >>>> +			!= DMA_COMPLETE) {
> > >>>
> > >>> Can you please do: 
> > >>> +	if (tmo == 0 ||
> > >>> +	    dma->device_tx_status(dma_chan, cookie, NULL) != DMA_COMPLETE) {
> > >>
> > >> Documentation/CodingStyle:Chapter 2
> > >>
> > >> "Statements longer than 80 columns will be broken into sensible chunks, unless
> > >> exceeding 80 columns significantly increases readability and does not hide
> > >> information. Descendants are always substantially shorter than the parent and
> > >> are placed substantially to the right. The same applies to function headers..."
> > >>
> > >> am I misreading the CodingStyle here ?
> > > 
> > > I'm not sure what the issue is here.... What I proposed is still the
> > > same length as the original code. And what I suggested complies with the
> > > existing coding style that's already there.
> > 
> > Ugh ... I missed this obvious CodingStyle error.
> > 
> > What Dave is trying to say is that he (and I'm pretty sure everyone else
> > for that matter) disagree with you style change because you have not broken
> > the columns into "sensible chunks".
> > 
> > IOW ... this,
> > 
> > 	if (tmo == 0 ||
> > 	    dma->device_tx_status(dma_chan, cookie, NULL) != DMA_COMPLETE) {
> > 
> > is much easier to comprehend than this,
> > 
> > 	if (tmo == 0 || dma->device_tx_status(dma_chan, cookie, NULL)
> > 			!= DMA_COMPLETE) {
> >
> agreed - it was just not clear to me how strict things should
> be applied - e.g. the indentation with spaces - will cleanup and
> resend.

Thank you. In general as a rule of thumb, apply coding style that's
consistent with the code that's already there. That makes it easy for
readability because it does not deviate from the whole. 
��.n��������+%������w��{.n��������)�)��jg��������ݢj����G�������j:+v���w�m������w�������h�����٥




[Index of Archives]     [Linux Kernel]     [Linux ARM (vger)]     [Linux ARM MSM]     [Linux Omap]     [Linux Arm]     [Linux Tegra]     [Fedora ARM]     [Linux for Samsung SOC]     [eCos]     [Linux PCI]     [Linux Fastboot]     [Gcc Help]     [Git]     [DCCP]     [IETF Announce]     [Security]     [Linux MIPS]     [Yosemite Campsites]

  Powered by Linux