On Mon, Dec 09, 2024 at 07:57:58AM +0900, Damien Le Moal wrote: > +int blkdev_issue_zone_zeroout(struct block_device *bdev, sector_t sector, > + sector_t nr_sects, gfp_t gfp_mask) Nit: Would blk_zone_issue_zeroout be a better name? Also I think this needs to be re-ordered before the previous patch to preserve bisectability. > +EXPORT_SYMBOL(blkdev_issue_zone_zeroout); EXPORT_SYMBOL_GPL is used for all other zoned code, I'd do the same here for consitency.