On Wed, 2024-08-28 at 18:17 -0400, Benjamin Marzinski wrote: > Instead of pp->offline being a binary value, change it to show the > actual result of looking at the sysfs state, and rename it to > pp->sysfs_state. Also change the function name from path_offline() to > path_sysfs_state(). Adapt the tests for pp->offline. This should not > change how multipath currently works. pp->sysfs_state will be used in > future patches. > > Signed-off-by: Benjamin Marzinski <bmarzins@xxxxxxxxxx> > --- > libmultipath/discovery.c | 65 ++++++++++++++++------------- > -- > libmultipath/discovery.h | 2 +- > libmultipath/libmultipath.version | 3 +- > libmultipath/print.c | 2 +- > libmultipath/structs.h | 2 +- > multipathd/main.c | 4 +- > 6 files changed, 41 insertions(+), 37 deletions(-) > > diff --git a/libmultipath/libmultipath.version > b/libmultipath/libmultipath.version > index 21d48da6..6439d3a7 100644 > --- a/libmultipath/libmultipath.version > +++ b/libmultipath/libmultipath.version > @@ -146,7 +146,7 @@ global: > path_discovery; > path_get_tpgs; > pathinfo; > - path_offline; > + path_sysfs_state; > print_all_paths; > print_foreign_topology; > print_multipath_topology__; > @@ -160,6 +160,7 @@ global: > remove_wwid; > replace_wwids; > reset_checker_classes; > + start_checker; > select_all_tg_pt; > select_action; > select_find_multipaths_timeout; Nit: This hunk belongs in 06/15. Otherwise, LGTM.