On 2/5/24 15:48, Damien Le Moal wrote:
On 2/6/24 02:48, Bart Van Assche wrote:
On 2/1/24 23:30, Damien Le Moal wrote:
+#define blk_zone_wplug_lock(zwplug, flags) \
+ spin_lock_irqsave(&zwplug->lock, flags)
+
+#define blk_zone_wplug_unlock(zwplug, flags) \
+ spin_unlock_irqrestore(&zwplug->lock, flags)
Hmm ... these macros may make code harder to read rather than improve
readability of the code.
I do not see how they make the code less readable. The macro names are not clear
enough ?
The macro names are clear but the macro names are almost as long as the
macro definitions. Usually this is a sign that it's better not to
introduce macros and instead inline the macros.
Thanks,
Bart.