On Tue, Apr 05, 2022 at 01:47:46PM -0600, Jane Chu wrote: > + pmem_clear_bb(pmem, to_sect(pmem, offset), cleared >> SECTOR_SHIFT); > + return (cleared < len) ? BLK_STS_IOERR : BLK_STS_OK; No need for the braces. That being said perosnally I find a simple: if (cleared < len) return BLK_STS_IOERR; return BLK_STS_OK; much easier to read anyway. Otherwise looks good: Reviewed-by: Christoph Hellwig <hch@xxxxxx> -- dm-devel mailing list dm-devel@xxxxxxxxxx https://listman.redhat.com/mailman/listinfo/dm-devel