I don't like where this is going. I think the model of storing the polling cookie in the bio is useful, but: (1) I think having this in the iter is a mess. Can you measure if just marking bvec_iter __packed will generate much worse code at all anymore? If not we can just move this into the bio If it really generates much worse code I think you need to pick a different name as as that i really confusing vs the bio field of the same name that is used entirely differenly. Similarly the bio_get_private_data and bio_set_private_data helpers are entirely misnamed, as the names suggest they deal with the bi_private field in struct bio. I actually suspect not having these helpers would be much preferable (2) once we do have the cookie in the bio we need to take advantage of that properly. That is stop returning the cookie up the stack as we do right now but just rely on the bio, which will clean up tons of crap. -- dm-devel mailing list dm-devel@xxxxxxxxxx https://listman.redhat.com/mailman/listinfo/dm-devel