+ switch (nvme_req_disposition(req)) {
+ case COMPLETE:
+ nvme_complete_req(req);
nvme_complete_rq calling nvme_complete_req... Maybe call it
__nvme_complete_rq instead?
That's what I had first, but it felt so strangely out of place next
to the other nvme_*_req calls..
Maybe nvme_complete_rq needs to be renamed - what about nvme_req_done?
I'd suggest to call nvme_complete_rq nvme_end_rq because it really calls
blk_mq_end_request. That would confuse with nvme_end_request which
calls blk_mq_complete_request... Maybe we need some naming improvements
throughout.
Maybe call nvme_req_disposition again locally here to not carry
the is_ana_status. But not a biggy..
That means it would have to become non-static in scope, limiting
inlining possibilities, etc.
I see.
--
dm-devel mailing list
dm-devel@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/dm-devel