Use signal_pending_state() instead of open-coding it. This patch does not change any functionality but makes it possible to pass TASK_KILLABLE as the second argument of dm_wait_for_completion(). See also commit 16882c1e962b ("sched: fix TASK_WAKEKILL vs SIGKILL race"). Signed-off-by: Bart Van Assche <bart.vanassche@xxxxxxxxxxx>. --- drivers/md/dm.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/md/dm.c b/drivers/md/dm.c index 1d3627c..7cce09e 100644 --- a/drivers/md/dm.c +++ b/drivers/md/dm.c @@ -1948,8 +1948,7 @@ static int dm_wait_for_completion(struct mapped_device *md, int sleep_state) if (!md_in_flight(md)) break; - if (sleep_state == TASK_INTERRUPTIBLE && - signal_pending(current)) { + if (signal_pending_state(sleep_state, current)) { r = -EINTR; break; } -- 2.9.3 -- dm-devel mailing list dm-devel@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/dm-devel