On Fri, Oct 25 2013 at 3:53pm -0400, Alasdair G Kergon <agk@xxxxxxxxxx> wrote: > On Thu, Oct 24, 2013 at 02:30:27PM -0400, Mike Snitzer wrote: > > From: Heinz Mauelshagen <heinzm@xxxxxxxxxx> > > > Use is_write_io() consistently where it is makes sense. > > > +++ b/drivers/md/dm-cache-target.c > > > +static bool is_write_io(struct bio *bio) > > +{ > > + return bio_data_dir(bio) == WRITE; > > +} > > I'm not really convinced about this one, though I can see some superficial > attractiveness. I think introducing it in a single file (rather than > kernel-wide) is obfuscating the code rather than making it more readable. > > If a change like this were to happen, wouldn't fs.h be a better place? is_write_io() was already in dm-cache-target.c, this patch just makes use of it in more applicable places. But I'm fine with completely eliminating is_write_io()... whatever others would prefer. -- dm-devel mailing list dm-devel@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/dm-devel