On Mon, Sep 24, 2012 at 03:34:46PM -0700, Kent Overstreet wrote: [..] > diff --git a/include/linux/bio.h b/include/linux/bio.h > index 4e32be1..d985e90 100644 > --- a/include/linux/bio.h > +++ b/include/linux/bio.h > @@ -67,6 +67,7 @@ > #define bio_offset(bio) bio_iovec((bio))->bv_offset > #define bio_segments(bio) ((bio)->bi_vcnt - (bio)->bi_idx) > #define bio_sectors(bio) ((bio)->bi_size >> 9) > +#define bio_end_sector(bio) ((bio)->bi_sector + bio_sectors(bio)) May be it is just me. But bio_end_sector() kind of sounds that it will calculate to the last sector of bio. So I thought of it more as bio_last_sector() and not the sector which is next to the last sector. Will it make sense to introduce bio_last_sector() and use +1 everywhere. Or may be we need a better name. Can't think of one though. Thanks Vivek -- dm-devel mailing list dm-devel@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/dm-devel