On Thu, Sep 20, 2012 at 04:32:25PM -0700, Tejun Heo wrote: > On Mon, Sep 10, 2012 at 05:22:16PM -0700, Kent Overstreet wrote: > > Just a little convenience macro - main reason to add it now is preparing > > for immutable bio vecs, it'll reduce the size of the patch that puts > > bi_sector/bi_size/bi_idx into a struct bvec_iter. > > > > Signed-off-by: Kent Overstreet <koverstreet@xxxxxxxxxx> > > CC: Jens Axboe <axboe@xxxxxxxxx> > > diff --git a/include/linux/bio.h b/include/linux/bio.h > > index 6763cdf..92bff0e 100644 > > --- a/include/linux/bio.h > > +++ b/include/linux/bio.h > > @@ -67,6 +67,7 @@ > > #define bio_offset(bio) bio_iovec((bio))->bv_offset > > #define bio_segments(bio) ((bio)->bi_vcnt - (bio)->bi_idx) > > #define bio_sectors(bio) ((bio)->bi_size >> 9) > > +#define bio_end(bio) ((bio)->bi_sector + bio_sectors(bio)) > > Maybe bio_end_sector() is a better name? bio_end() looks a bit too > close to bio_endio(). Bit verbose for my tastes, but I tend to be more terse than most :P I'm used to bio_end(), but I'll probably change it. -- dm-devel mailing list dm-devel@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/dm-devel