On 2011-05-31 16:28, Martin K. Petersen wrote: >>>>>> "Jens" == Jens Axboe <jaxboe@xxxxxxxxxxxx> writes: > > Jens> On 2011-05-31 04:19, Martin K. Petersen wrote: >>> - queue_flag_set_unlocked(QUEUE_FLAG_NONROT, disk->queue); >>> + blk_queue_non_rotational(queue); > > Jens> I don't like this part of the change. Before it was immediately > Jens> apparently that we were setting this flag, know you have no idea > Jens> what it does. Please make that blk_queue_set_non_rotational(). > > I was just trying to mimic the rest of the topology calls. > > How about: > > blk_queue_rotational(q, BLK_QUEUE_ROTATIONAL|BLK_QUEUE_NON_ROTATIONAL) > > Doing it that way would make the code clearer a few places too, I > think... I prefer having the function names be descriptive instead, but consistency is good as well. The problem with the above approach is that it usually requires defines to match, otherwise you don't know what the arguments do. So lets rather fix up the other names for the next kernel. -- Jens Axboe -- dm-devel mailing list dm-devel@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/dm-devel