Re: [PATCH] DM RAID: add RAID1 support

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



> +#ifdef md_raid1_congested
> +	if (rs->raid_type->level == 1)
> +		return md_raid1_congested(&rs->md, bits);
> +#endif
> +
>  	return md_raid5_congested(&rs->md, bits);

How well is this tested?  md_raid1_congested is a not a cpp macro
in your md patch, so with that patch it never would be called.

Also I think the congested call really should go through function
pointer indirections instead of opencoding all possible variants like
this.

--
dm-devel mailing list
dm-devel@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/dm-devel


[Index of Archives]     [DM Crypt]     [Fedora Desktop]     [ATA RAID]     [Fedora Marketing]     [Fedora Packaging]     [Fedora SELinux]     [Yosemite Discussion]     [KDE Users]     [Fedora Docs]

  Powered by Linux