Quite a lot of churn but I think it is for the better in the end. (I developed these changes on Wednesday but just got around to getting them sent out now) Mike Snitzer (7): document low hanging fruit to help improve code readability Improve name used for "persistent store" in 'struct dm_multisnap' Avoid exception store being confused with snapshot 's' Avoid struct members with the name 'dm' rename snapid members to use 'snapid' names move individual dm_multisnap 'flags' values Removed remaining 'struct dm_exception_store' FIXMEs. drivers/md/dm-multisnap-alloc.c | 271 +++++++++--------- drivers/md/dm-multisnap-blocks.c | 118 ++++---- drivers/md/dm-multisnap-btree.c | 330 +++++++++++----------- drivers/md/dm-multisnap-commit.c | 140 +++++----- drivers/md/dm-multisnap-daniel.c | 32 +- drivers/md/dm-multisnap-delete.c | 70 +++--- drivers/md/dm-multisnap-freelist.c | 96 ++++---- drivers/md/dm-multisnap-io.c | 148 +++++----- drivers/md/dm-multisnap-mikulas-struct.h | 8 +- drivers/md/dm-multisnap-mikulas.c | 441 +++++++++++++++--------------- drivers/md/dm-multisnap-mikulas.h | 110 ++++---- drivers/md/dm-multisnap-private.h | 8 +- drivers/md/dm-multisnap-snaps.c | 234 ++++++++-------- drivers/md/dm-multisnap.c | 72 +++--- drivers/md/dm-multisnap.h | 38 ++-- 15 files changed, 1060 insertions(+), 1056 deletions(-) -- dm-devel mailing list dm-devel@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/dm-devel