Milan Broz wrote: > Hannes Reinecke wrote: >>> + /* partitions handled in userspace, just send change event */ >>> + if (disk_userspace_partitions(disk)) { >>> + kobject_uevent(&disk_to_dev(disk)->kobj, KOBJ_CHANGE); >>> + return 0; >>> + } >>> + >> Wrong. If you do it here, you'll never be able to catch any size changes >> of the disk. You'll have to move it to after the 'bdev->bd_invalidated = 0' >> line. > > Yes, for non-DM devices which want to use that flag. > > For device-mapper device, size can change only by mapping table change > which always generate change uevent. > Okay. But the whole point of my objections is to make the flag useable for the general populace, so that my second patch can take advantage of it. >> I would suggest renaming it to GENHD_FL_USERSPACE_PARTITIONS, as this is >> more in line with the function of the flag. > > no problem here:-) Hmm. I've send an updated patch, but it seems to be stuck in the mailqueue somewhere. The second patch went through, though ... curious. Cheers, Hannes -- Dr. Hannes Reinecke zSeries & Storage hare@xxxxxxx +49 911 74053 688 SUSE LINUX Products GmbH, Maxfeldstr. 5, 90409 Nürnberg GF: Markus Rex, HRB 16746 (AG Nürnberg) -- dm-devel mailing list dm-devel@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/dm-devel