Re: goto patch for cryptsetup?

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, Mar 07, 2014 at 11:52:12 CET, Lars Winterfeld wrote:
> Am 03/07/2014 06:23 AM, schrieb Milan Broz:
> > On 03/06/2014 09:39 PM, Lars Winterfeld wrote:
> >> Hi,
> >>
> >> in light of the latest "goto fail"s out there, would you reject a patch
> >> replacing all 328 gotos with their semantic equivalents from structured
> >> C programming?
> > 
> > cryptsetup code uss goto for only one purpose: to have only one exit
> > place from a function (with check for errors, release memory).
> > 
> > Replacing it with anything else means duplicating of lot of code.
> 
> I agree that code duplication is undesirable. I can think of two
> alternatives to goto that do not duplicate code. The first is to
> introduce a one-time loop like this:
> 
> do {
> // foo
> if(a) break; // was: goto out;
> // bar
> if(b) break; // was: goto out;
> // "all good" code
> return 0;
> } while(0);
> // was: out:
> // "on error" code
> return -1;

Urgh. That is exceedingly ugly and even less readable than 
with goto, as it misuses a loop as goto.Pleas do not do such
things, the cure is worse than the disease.
 
> The second alternative would be to introduce a new function like
> 
> int foo_failed(struct bar* p) {
> 	// clean p
> 	return -1;
> }
> 
> and then inside the "int foo()":
> if(a) return foo_failed(p);
> instead of
> if(a) goto fail;

And there you will get scoping problems and need to put stuff in 
structs just so you can pass them as argument. Not good.
 
> Like with indentation, I think this is just a question of coding style.
> Changes there don't make the program better, it just makes the code
> nicer to read in the eyes of some people.

Not me. Both your examples are harder to read. I do not
think getting rid of goto helps in any way as long as
goto is used competently and with restraint. In this
case, it is often superiour to other constructs.
 
Arno

> It's up to you. I would do the work. What do you think?
> 
> Cheers,
> Lars
> 
> 



> _______________________________________________
> dm-crypt mailing list
> dm-crypt@xxxxxxxx
> http://www.saout.de/mailman/listinfo/dm-crypt


-- 
Arno Wagner,     Dr. sc. techn., Dipl. Inform.,    Email: arno@xxxxxxxxxxx
GnuPG: ID: CB5D9718  FP: 12D6 C03B 1B30 33BB 13CF  B774 E35C 5FA1 CB5D 9718
----
A good decision is based on knowledge and not on numbers. -  Plato
_______________________________________________
dm-crypt mailing list
dm-crypt@xxxxxxxx
http://www.saout.de/mailman/listinfo/dm-crypt




[Index of Archives]     [Device Mapper Devel]     [Fedora Desktop]     [ATA RAID]     [Fedora Marketing]     [Fedora Packaging]     [Fedora SELinux]     [Yosemite News]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux