On Tue, 4 Mar 2025 09:25:24 +0100 Krzysztof Kozlowski <krzk@xxxxxxxxxx> wrote: Hi, > On Tue, Mar 04, 2025 at 01:27:54AM +0000, Andre Przywara wrote: > > The Allwinner A523/T527 SoCs have four CCUs, this adds the binding for > > the main CCU. > > > > The source clock list differs in some annoying details, and folding this > > into the existing Allwinner CCU clock binding document gets quite > > unwieldy, so create a new document for these CCUs. > > Add the new compatible string, along with the required input clock > > lists. This conditionally describes the input clock list, to make for > > an easier patch adding the other CCUs. > > > > Also add the DT binding headers, listing all the clocks with their ID > > numbers. > > > > Signed-off-by: Andre Przywara <andre.przywara@xxxxxxx> > > --- > > .../clock/allwinner,sun55i-a523-ccu.yaml | 77 +++++++ > > include/dt-bindings/clock/sun55i-a523-ccu.h | 189 ++++++++++++++++++ > > include/dt-bindings/reset/sun55i-a523-ccu.h | 88 ++++++++ > > 3 files changed, 354 insertions(+) > > create mode 100644 Documentation/devicetree/bindings/clock/allwinner,sun55i-a523-ccu.yaml > > create mode 100644 include/dt-bindings/clock/sun55i-a523-ccu.h > > create mode 100644 include/dt-bindings/reset/sun55i-a523-ccu.h > > > > diff --git a/Documentation/devicetree/bindings/clock/allwinner,sun55i-a523-ccu.yaml b/Documentation/devicetree/bindings/clock/allwinner,sun55i-a523-ccu.yaml > > new file mode 100644 > > index 0000000000000..2eacaeaeabac7 > > --- /dev/null > > +++ b/Documentation/devicetree/bindings/clock/allwinner,sun55i-a523-ccu.yaml > > @@ -0,0 +1,77 @@ > > +# SPDX-License-Identifier: (GPL-2.0-only OR BSD-2-Clause) > > +%YAML 1.2 > > +--- > > +$id: http://devicetree.org/schemas/clock/allwinner,sun55i-a523-ccu.yaml# > > +$schema: http://devicetree.org/meta-schemas/core.yaml# > > + > > +title: Allwinner A523 Clock Control Unit > > + > > +maintainers: > > + - Andre Przywara <andre.przywara@xxxxxxx> > > + > > +properties: > > + "#clock-cells": > > + const: 1 > > + > > + "#reset-cells": > > + const: 1 > > + > > + compatible: > > + enum: > > + - allwinner,sun55i-a523-ccu > > + > > + reg: > > + maxItems: 1 > > + > > + clocks: > > + minItems: 4 > > Drop, redundant. > > > + maxItems: 4 > > + > > + clock-names: > > + minItems: 4 > > + maxItems: 4 > > Drop both and instead you need to list the items. > > > + > > +required: > > + - "#clock-cells" > > + - "#reset-cells" > > + - compatible > > + - reg > > + - clocks > > + - clock-names > > + > > +if: > > Drop, you have here only one device, no need for if:then. I know, and I do understand the redundancy of the minItems/maxItems above, but as I wrote in the commit message, this paves the way for the follow up patch and makes both more readable. Apart from helping with the review, I didn't want to conflate both devices into one patch, I think I saw people complaining about that in the past. If you are fine with having them both added all in one go, I am happy to just squash the patches. Cheers, Andre > > Best regards, > Krzysztof >