On Mon, 24 Feb 2025 20:33:16 +0200 Matti Vaittinen <mazziesaccount@xxxxxxxxx> wrote: > There are ADC ICs which may have some of the AIN pins usable for other > functions. These ICs may have some of the AIN pins wired so that they > should not be used for ADC. > > (Preferred?) way for marking pins which can be used as ADC inputs is to > add corresponding channels@N nodes in the device tree as described in > the ADC binding yaml. I think it's worth exploring if we can tweak this slightly to make that something a driver specifies. Either skip the unspecified or fill them with default values depending on a parameter. Would make this code cover the existing cases better. Might be a little fiddly as we'd want to maintain ordering so the code would need to index slightly differently. I've not tried it so maybe not worth it for now. > > Add couple of helper functions which can be used to retrieve the channel > information from the device node. > > Signed-off-by: Matti Vaittinen <mazziesaccount@xxxxxxxxx> > > --- > Revision history: > v3 => v4: > - Drop diff-channel support > - Drop iio_adc_device_channels_by_property() > - Add IIO_DEVICE namespace > - Move industrialio-adc.o to top of the Makefile > - Some styling as suggested by Andy > - Re-consider included headers > v2 => v3: Mostly based on review comments by Jonathan > - Support differential and single-ended channels > - Rename iio_adc_device_get_channels() as > iio_adc_device_channels_by_property() > - Improve spelling > - Drop support for cases where DT comes from parent device's node > - Decrease loop indent by reverting node name check conditions > - Don't set 'chan->indexed' by number of channels to keep the > interface consistent no matter how many channels are connected. > - Fix ID range check and related comment > RFC v1 => v2: > - New patch > > iio: adc: helper: drop headers > --- > drivers/iio/adc/Kconfig | 3 + > drivers/iio/adc/Makefile | 2 + > drivers/iio/adc/industrialio-adc.c | 89 ++++++++++++++++++++++++++++++ > include/linux/iio/adc-helpers.h | 22 ++++++++ > 4 files changed, 116 insertions(+) > create mode 100644 drivers/iio/adc/industrialio-adc.c > create mode 100644 include/linux/iio/adc-helpers.h > > diff --git a/drivers/iio/adc/Kconfig b/drivers/iio/adc/Kconfig > index 849c90203071..37b70a65da6f 100644 > --- a/drivers/iio/adc/Kconfig > +++ b/drivers/iio/adc/Kconfig > @@ -6,6 +6,9 @@ > > menu "Analog to digital converters" > > +config IIO_ADC_HELPER > + tristate > + > config AB8500_GPADC > bool "ST-Ericsson AB8500 GPADC driver" > depends on AB8500_CORE && REGULATOR_AB8500 > diff --git a/drivers/iio/adc/Makefile b/drivers/iio/adc/Makefile > index ee19afba62b7..1c410f483029 100644 > --- a/drivers/iio/adc/Makefile > +++ b/drivers/iio/adc/Makefile > @@ -3,6 +3,8 @@ > # Makefile for IIO ADC drivers > # > > +obj-$(CONFIG_IIO_ADC_HELPER) += industrialio-adc.o > + > # When adding new entries keep the list in alphabetical order > obj-$(CONFIG_AB8500_GPADC) += ab8500-gpadc.o > obj-$(CONFIG_AD_SIGMA_DELTA) += ad_sigma_delta.o > diff --git a/drivers/iio/adc/industrialio-adc.c b/drivers/iio/adc/industrialio-adc.c > new file mode 100644 > index 000000000000..d8e9e6825d2b > --- /dev/null > +++ b/drivers/iio/adc/industrialio-adc.c > @@ -0,0 +1,89 @@ > +// SPDX-License-Identifier: GPL-2.0-only > +/* > + * Helpers for parsing common ADC information from a firmware node. > + * > + * Copyright (c) 2025 Matti Vaittinen <mazziesaccount@xxxxxxxxx> > + */ > + > +#include <linux/device.h> > +#include <linux/errno.h> > +#include <linux/export.h> > +#include <linux/module.h> > +#include <linux/property.h> > +#include <linux/types.h> > + > +#include <linux/iio/adc-helpers.h> > +#include <linux/iio/iio.h> > + > +int iio_adc_device_num_channels(struct device *dev) > +{ > + return device_get_child_node_count_named(dev, "channel"); > +} > +EXPORT_SYMBOL_GPL(iio_adc_device_num_channels); Maybe one to promote to a static inline in the header and avoid need for the export given it is very simple. > + > +/** > + * devm_iio_adc_device_alloc_chaninfo_se - allocate and fill iio_chan_spec for ADC > + * > + * Scan the device node for single-ended ADC channel information. Channel ID is > + * expected to be found from the "reg" property. Allocate and populate the > + * iio_chan_spec structure corresponding to channels that are found. The memory > + * for iio_chan_spec structure will be freed upon device detach. > + * > + * @dev: Pointer to the ADC device. > + * @template: Template iio_chan_spec from which the fields of all > + * found and allocated channels are initialized. > + * @max_chan_id: Maximum value of a channel ID. Use -1 if no checking > + * is required. > + * @cs: Location where pointer to allocated iio_chan_spec > + * should be stored. > + * > + * Return: Number of found channels on succes. Negative value to indicate > + * failure. > + */ > +int devm_iio_adc_device_alloc_chaninfo_se(struct device *dev, > + const struct iio_chan_spec *template, > + int max_chan_id, > + struct iio_chan_spec **cs) > +{ > + struct iio_chan_spec *chan_array, *chan; > + int num_chan = 0, ret; > + > + num_chan = iio_adc_device_num_channels(dev); > + if (num_chan < 1) > + return num_chan; > + > + chan_array = devm_kcalloc(dev, num_chan, sizeof(*chan_array), > + GFP_KERNEL); > + if (!chan_array) > + return -ENOMEM; > + > + chan = &chan_array[0]; > + > + device_for_each_child_node_scoped(dev, child) { > + u32 ch; > + > + if (!fwnode_name_eq(child, "channel")) > + continue; > + > + ret = fwnode_property_read_u32(child, "reg", &ch); > + if (ret) > + return ret; > + > + if (max_chan_id != -1) > + if (ch > max_chan_id) > + return -ERANGE; Might as well combine. if (max_chan_id != -1 && ch > max_chan_id) return -ERANGE; > + > + *chan = *template; > + chan->channel = ch; > + chan++; > + } > + > + *cs = chan_array; > + > + return num_chan; > +} > +EXPORT_SYMBOL_NS_GPL(devm_iio_adc_device_alloc_chaninfo_se, "IIO_DRIVER"); > + > +MODULE_LICENSE("GPL"); > +MODULE_AUTHOR("Matti Vaittinen <mazziesaccount@xxxxxxxxx>"); > +MODULE_DESCRIPTION("IIO ADC fwnode parsing helpers");