On Wed, Feb 05, 2025 at 11:23:16PM -0800, Atish Patra wrote: > With Ssccfg/Smcdeleg, we no longer need SBI PMU extension to program/ > access hpmcounter/events. However, we do need it for firmware counters. > Rename the driver and its related code to represent generic name > that will handle both sbi and ISA mechanism for hpmcounter related > operations. Take this opportunity to update the Kconfig names to > match the new driver name closely. > > No functional change intended. > > Signed-off-by: Atish Patra <atishp@xxxxxxxxxxxx> > --- > MAINTAINERS | 4 +- > arch/riscv/include/asm/kvm_vcpu_pmu.h | 4 +- > arch/riscv/include/asm/kvm_vcpu_sbi.h | 2 +- > arch/riscv/kvm/Makefile | 4 +- > arch/riscv/kvm/vcpu_sbi.c | 2 +- > drivers/perf/Kconfig | 16 +- > drivers/perf/Makefile | 4 +- > drivers/perf/{riscv_pmu.c => riscv_pmu_common.c} | 0 > drivers/perf/{riscv_pmu_sbi.c => riscv_pmu_dev.c} | 214 +++++++++++++--------- This seems... gratuitous? It feels like renaming the file could be a pain for managing backports and renaming the driver might cause some headaches in userspace. What do you gain from such an invasive change? Will