On Wed, Jan 22, 2025 at 06:42:51PM +0100, Maxime Chevallier wrote: > The ability to describe the physical ports of Ethernet devices is useful > to describe multi-port devices, as well as to remove any ambiguity with > regard to the nature of the port. > > Moreover, describing ports allows for a better description of features > that are tied to connectors, such as PoE through the PSE-PD devices. Seems like we need a connector binding like we've ended up needing in other cases. > > Introduce a binding to allow describing the ports, for now with 2 > attributes : > > - The number of lanes, which is a quite generic property that allows > differentating between multiple similar technologies such as BaseT1 > and "regular" BaseT (which usually means BaseT4). > > - The media that can be used on that port, such as BaseT for Twisted > Copper, BaseC for coax copper, BaseS/L for Fiber, BaseK for backplane > ethernet, etc. This allows defining the nature of the port, and > therefore avoids the need for vendor-specific properties such as > "micrel,fiber-mode" or "ti,fiber-mode". > > The port description lives in its own file, as it is intended in the > future to allow describing the ports for phy-less devices. > > Signed-off-by: Maxime Chevallier <maxime.chevallier@xxxxxxxxxxx> > --- > RFC V2: New patch > > .../devicetree/bindings/net/ethernet-phy.yaml | 18 +++++++ > .../bindings/net/ethernet-port.yaml | 47 +++++++++++++++++++ > 2 files changed, 65 insertions(+) > create mode 100644 Documentation/devicetree/bindings/net/ethernet-port.yaml > > diff --git a/Documentation/devicetree/bindings/net/ethernet-phy.yaml b/Documentation/devicetree/bindings/net/ethernet-phy.yaml > index 2c71454ae8e3..950fdacfd27d 100644 > --- a/Documentation/devicetree/bindings/net/ethernet-phy.yaml > +++ b/Documentation/devicetree/bindings/net/ethernet-phy.yaml > @@ -261,6 +261,17 @@ properties: > > additionalProperties: false > > + mdi: > + type: object > + > + patternProperties: > + '^port-[a-f0-9]+$': 'port' is already a node name for graphs. It's also the deprecated name for 'ethernet-port' in the switch/DSA bindings. > + $ref: /schemas/net/ethernet-port.yaml# A confusing name considering we already have 'ethernet-port'. Rob