Re: [PATCH v5 3/9] drm: bridge: inno-hdmi: add inno bridge driver.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, Nov 21, 2024 at 02:06:20AM +0000, Keith Zhao wrote:
> 
> 
> > -----Original Message-----
> > From: Uwe Kleine-König <u.kleine-koenig@xxxxxxxxxxxx>
> > Sent: 2024年11月20日 22:56
> > To: Keith Zhao <keith.zhao@xxxxxxxxxxxxxxxx>
> > Cc: devicetree@xxxxxxxxxxxxxxx; dri-devel@xxxxxxxxxxxxxxxxxxxxx;
> > andrzej.hajda@xxxxxxxxx; neil.armstrong@xxxxxxxxxx; rfoss@xxxxxxxxxx;
> > Laurent.pinchart@xxxxxxxxxxxxxxxx; jernej.skrabec@xxxxxxxxx;
> > maarten.lankhorst@xxxxxxxxxxxxxxx; mripard@xxxxxxxxxx;
> > tzimmermann@xxxxxxx; airlied@xxxxxxxxx; simona@xxxxxxxx;
> > robh@xxxxxxxxxx; krzk+dt@xxxxxxxxxx; conor+dt@xxxxxxxxxx;
> > hjc@xxxxxxxxxxxxxx; heiko@xxxxxxxxx; andy.yan@xxxxxxxxxxxxxx; William Qiu
> > <william.qiu@xxxxxxxxxxxxxxxx>; Xingyu Wu <xingyu.wu@xxxxxxxxxxxxxxxx>;
> > kernel@xxxxxxxx; paul.walmsley@xxxxxxxxxx; palmer@xxxxxxxxxxx;
> > aou@xxxxxxxxxxxxxxxxx; p.zabel@xxxxxxxxxxxxxx; Changhuang Liang
> > <changhuang.liang@xxxxxxxxxxxxxxxx>; Jack Zhu <jack.zhu@xxxxxxxxxxxxxxxx>;
> > linux-kernel@xxxxxxxxxxxxxxx
> > Subject: Re: [PATCH v5 3/9] drm: bridge: inno-hdmi: add inno bridge driver.
> > 
> > Hello,
> > 
> > On Wed, Nov 20, 2024 at 02:18:42PM +0800, keith zhao wrote:
> > > +struct platform_driver inno_hdmi_driver = {
> > > +	.probe  = inno_hdmi_rockchip_probe,
> > > +	.remove_new = inno_hdmi_rockchip_remove,
> > 
> > Please use .remove instead of .remove_new.
> > 
> Thank you for the clarification regarding .remove_new. 
> I understand that it's a relic and that new drivers should implement .remove().
> 
> I have a question. One of the changes in this patch is to rename some function interfaces. 
> The original code is like this. 
> 
> struct platform_driver inno_hdmi_driver = {
> 	.probe  = inno_hdmi_probe,
> 	.remove_new = inno_hdmi_remove,
> 	.driver = {
> 		.name = "innohdmi-rockchip",
> 		.of_match_table = inno_hdmi_dt_ids,
> 	},
> };
> 
> Rename inno_hdmi_probe and inno_hdmi_remove
> struct platform_driver inno_hdmi_driver = {
> 	.probe  = inno_hdmi_rockchip_probe,
> 	.remove_new = inno_hdmi_rockchip_remove,
> 	.driver = {
> 		.name = "innohdmi-rockchip",
> 		.of_match_table = inno_hdmi_dt_ids,
> 	},
> };
> Based on the principle of maintaining consistency, 
> does it(remove_new) need to be changed?

If this isn't new code but moving from somewhere, don't change
.remove_new into .remove in the same patch. If you want, fix that in a
separate patch then.

Best regards
Uwe

Attachment: signature.asc
Description: PGP signature


[Index of Archives]     [Device Tree Compilter]     [Device Tree Spec]     [Linux Driver Backports]     [Video for Linux]     [Linux USB Devel]     [Linux PCI Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [XFree86]     [Yosemite Backpacking]


  Powered by Linux