On Fri, Oct 11, 2024 at 12:32:12PM +0800, kernel test robot wrote: > Hi Vasileios, > > kernel test robot noticed the following build warnings: > > [auto build test WARNING on 96be67caa0f0420d4128cb67f07bbd7a6f49e03a] > > url: https://github.com/intel-lab-lkp/linux/commits/Vasileios-Amoiridis/iio-pressure-bmp280-Use-sleep-and-forced-mode-for-oneshot-captures/20241008-035238 > base: 96be67caa0f0420d4128cb67f07bbd7a6f49e03a > patch link: https://lore.kernel.org/r/20241007194945.66192-2-vassilisamir%40gmail.com > patch subject: [PATCH v8 1/4] iio: pressure: bmp280: Use sleep and forced mode for oneshot captures > config: i386-randconfig-006-20241011 (https://download.01.org/0day-ci/archive/20241011/202410111221.YIeXHxOv-lkp@xxxxxxxxx/config) > compiler: clang version 18.1.8 (https://github.com/llvm/llvm-project 3b5b5c1ec4a3095ab096dd780e84d7ab81f3d7ff) > reproduce (this is a W=1 build): (https://download.01.org/0day-ci/archive/20241011/202410111221.YIeXHxOv-lkp@xxxxxxxxx/reproduce) > > If you fix the issue in a separate patch/commit (i.e. not just a new version of > the same patch/commit), kindly add following tags > | Reported-by: kernel test robot <lkp@xxxxxxxxx> > | Closes: https://lore.kernel.org/oe-kbuild-all/202410111221.YIeXHxOv-lkp@xxxxxxxxx/ > > All warnings (new ones prefixed by >>): > > >> drivers/iio/pressure/bmp280-core.c:1051:3: warning: variable 'meas_time_us' is uninitialized when used here [-Wuninitialized] > 1051 | meas_time_us += BMP280_PRESS_HUMID_MEAS_OFFSET + > | ^~~~~~~~~~~~ > drivers/iio/pressure/bmp280-core.c:1046:32: note: initialize the variable 'meas_time_us' to silence this warning > 1046 | unsigned int reg, meas_time_us; > | ^ > | = 0 > drivers/iio/pressure/bmp280-core.c:2452:2: warning: variable 'offset' is uninitialized when used here [-Wuninitialized] > 2452 | offset += sizeof(s32); > | ^~~~~~ > drivers/iio/pressure/bmp280-core.c:2437:17: note: initialize the variable 'offset' to silence this warning > 2437 | int ret, offset; > | ^ > | = 0 Rarely, but looks like this suggestion is okay, rather I would do it as 'else' branch and convert '+=' in the 'if' part to be '='. -- With Best Regards, Andy Shevchenko