On Tue, Mar 03, 2015 at 01:29:34PM +0100, Daniel Lezcano wrote: > Call the common ARM/ARM64 'arm_cpuidle_suspend' instead of cpu_suspend function > which is specific to ARM64. > > Signed-off-by: Daniel Lezcano <daniel.lezcano@xxxxxxxxxx> > --- > drivers/cpuidle/cpuidle-arm64.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/cpuidle/cpuidle-arm64.c b/drivers/cpuidle/cpuidle-arm64.c > index 39a2c62..0cea244 100644 > --- a/drivers/cpuidle/cpuidle-arm64.c > +++ b/drivers/cpuidle/cpuidle-arm64.c > @@ -49,7 +49,7 @@ static int arm64_enter_idle_state(struct cpuidle_device *dev, > * call the CPU ops suspend protocol with idle index as a > * parameter. > */ > - ret = cpu_suspend(idx); > + arm_cpuidle_suspend(idx); Nitpick: why don't we just rename the arm one cpuidle_suspend()? -- Catalin -- To unsubscribe from this list: send the line "unsubscribe devicetree" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html