Re: [PATCH] dt-bindings: dma: sprd,sc9860-dma: convert to YAML

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, Jul 04, 2024 at 05:18:09PM +0200, Stanislav Jakubek wrote:
> Convert the Spreadtrum SC9860 DMA bindings to DT schema.
> 
> Changes during conversion:
>   - rename file to match compatible
>   - make interrupts optional, the AGCP DMA controller doesn't need it
>   - describe the optional ashb_eb clock for the AGCP DMA controller
> 
> Signed-off-by: Stanislav Jakubek <stano.jakubek@xxxxxxxxx>
> ---
>  .../bindings/dma/sprd,sc9860-dma.yaml         | 92 +++++++++++++++++++
>  .../devicetree/bindings/dma/sprd-dma.txt      | 44 ---------
>  2 files changed, 92 insertions(+), 44 deletions(-)
>  create mode 100644 Documentation/devicetree/bindings/dma/sprd,sc9860-dma.yaml
>  delete mode 100644 Documentation/devicetree/bindings/dma/sprd-dma.txt
> 
> diff --git a/Documentation/devicetree/bindings/dma/sprd,sc9860-dma.yaml b/Documentation/devicetree/bindings/dma/sprd,sc9860-dma.yaml
> new file mode 100644
> index 000000000000..e1639593d26d
> --- /dev/null
> +++ b/Documentation/devicetree/bindings/dma/sprd,sc9860-dma.yaml
> @@ -0,0 +1,92 @@
> +# SPDX-License-Identifier: GPL-2.0-only OR BSD-2-Clause
> +%YAML 1.2
> +---
> +$id: http://devicetree.org/schemas/dma/sprd,sc9860-dma.yaml#
> +$schema: http://devicetree.org/meta-schemas/core.yaml#
> +
> +title: Spreadtrum SC9860 DMA controller
> +
> +description: |
> +  There are three DMA controllers: AP DMA, AON DMA and AGCP DMA. For AGCP
> +  DMA controller, it can or do not request the IRQ, which will save
> +  system power without resuming system by DMA interrupts if AGCP DMA
> +  does not request the IRQ.
> +
> +maintainers:
> +  - Orson Zhai <orsonzhai@xxxxxxxxx>
> +  - Baolin Wang <baolin.wang7@xxxxxxxxx>
> +  - Chunyan Zhang <zhang.lyra@xxxxxxxxx>
> +
> +properties:
> +  compatible:
> +    const: sprd,sc9860-dma
> +
> +  reg:
> +    maxItems: 1
> +
> +  interrupts:
> +    maxItems: 1
> +
> +  clocks:
> +    minItems: 1
> +    maxItems: 2
> +
> +  clock-names:
> +    oneOf:
> +      - const: enable
> +      # The ashb_eb clock is optional and only for AGCP DMA controller
> +      - items:
> +          - const: enable
> +          - const: ashb_eb

This is better written as:
  clock-names:
    minItems: 1
    items:
      - const: enable
      - const: ashb_eb

> +
> +  '#dma-cells':
> +    const: 1
> +
> +  dma-channels:
> +    const: 32
> +
> +  '#dma-channels':
> +    const: 32
> +    deprecated: true

If there are no users of this, I'd be inclined to just drop it from the
binding.

Cheers,
Conor.

Attachment: signature.asc
Description: PGP signature


[Index of Archives]     [Device Tree Compilter]     [Device Tree Spec]     [Linux Driver Backports]     [Video for Linux]     [Linux USB Devel]     [Linux PCI Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [XFree86]     [Yosemite Backpacking]


  Powered by Linux