Re: [PATCH net-next v3 03/10] net: pcs: xpcs: Convert xpcs_id to dw_xpcs_desc

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, Jun 27, 2024 at 03:10:18PM +0200, Andrew Lunn wrote:
> > -	for (i = 0; i < ARRAY_SIZE(xpcs_id_list); i++) {
> > -		const struct xpcs_id *entry = &xpcs_id_list[i];
> > +	for (i = 0; i < ARRAY_SIZE(xpcs_desc_list); i++) {
> > +		const struct dw_xpcs_desc *entry = &xpcs_desc_list[i];
> >  
> >  		if ((xpcs_id & entry->mask) != entry->id)
> >  			continue;
> >  
> > -		xpcs->id = entry;
> > +		xpcs->desc = entry;
> 
> Maybe rename entry to desc here?

Curiously to note that originally I had the same idea in mind and even
implemented it in the first v2 version. But then decided to preserve
the original name to signify that the pointer is a temporary
variable pointing to the desc list entry.

Anyway I don't mind changing the name to desc especially seeing I need
to resubmit the series anyway. Using the desc name here won't make
thing less readable here, but will also provide a notion about the
variable content.

I'll change the name to "desc" in v4.

> 
> Otherwise
> 
> Reviewed-by: Andrew Lunn <andrew@xxxxxxx>

Thanks.

-Serge(y)

> 
>     Andrew




[Index of Archives]     [Device Tree Compilter]     [Device Tree Spec]     [Linux Driver Backports]     [Video for Linux]     [Linux USB Devel]     [Linux PCI Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [XFree86]     [Yosemite Backpacking]


  Powered by Linux